Stopped working deadbeef-vs

Something changed in Ubuntu and the program deadbeef-vs stopped working.

error text in /var/log/syslog
Mar 26 10:03:59 vasilisc kernel: [ 8019.812227] traps: run.sh[15640] general protection fault ip:7f9386d0ded6 sp:7ffd32346928 error:0 in ld-2.23.so[7f9386cf6000+26000]

Error in Ubuntu 19.04
snap version
snap 2.38+19.04
snapd 2.38+19.04
series 16
ubuntu 19.04
kernel 5.0.0-7-generic

Error in Ubuntu 18.04
snap version
snap 2.37.4+18.04.1
snapd 2.37.4+18.04.1
series 16
ubuntu 18.04
kernel 4.15.0-46-generic

Error in Ubuntu 16.04
snap version
snap 2.37.4
snapd 2.37.4
series 16
ubuntu 16.04
kernel 4.15.0-39-generic

The author of the program is not me, but I am the author of the snap package.

I suspect OP is the publisher – but maybe they’re a different vasilisc.

1 Like

@vasilisc, your snap includes libc6, and also uses the libc6 from its base. I’d start by looking into that.

1 Like

@vasilisc @chipaca My bad :man_facepalming:

I swear that the program worked, I did not post the new version of the package.

yes, but the snap is built in such a way that it will only work if it has the exact same libc as its base, which is something best avoided.

1 Like

Thanks for answers. I fixed the problem.

Could you tel us how you fixed it, for posterity?

I have deleted any substring “libc” in the snapcraft.yaml file.