Snapd on ubuntu armf not looking for shop online

I have orange pi zero and just downloaded and installed its ubuntu server.

I successfully installed snapd (or so it seemed) following instructions.

When I run “snap find hello” I get:

oot@OrangePI:~# snap find hello
error: cannot list snaps: cannot communicate with server: Get http://localhost/v2/find?q=hello&scope=wide: dial unix /run/snapd.socket: connect: connection refused

Is that trying to find the shop on my local host?

What is the likely problem?

It looks like snapd isn’t running. What does sudo systemctl status snapd say? sudo systemctl start snapd will hopefully fix it.

I will often get a “cannot resolve host OrangePI” message when running sudo from root.

On reboot I keep getting “[FAILED] Failed to start Snappy daemon” nessage in console.

From shell, when I type “systemctl status snapd.service” it gives the following output:
Failed to issue method call: No such interface ‘org.freedesktop.DBus.Properties’ on object at path /org/freedesktop/systemd1/unit/snapd_2eservice

Ubuntu will be armhf Ubuntu 14.04.3 LTS.

Ah, that’s a very old, completely unofficial image, and by the sounds of it it might be a bit broken. Ubuntu 14.04 is from 2014 and natively uses Upstart rather than systemd. But snapd should still work.

snapd on Ubuntu 14.04 requires that systemd be running inside Upstart, which is set up when you install the snapd package. What does sudo service systemd restart say? Are there any mentions of systemd in /var/log/syslog?

why are you root, how did you become root ?

the Ubuntu Core images are set up in a way that only your created user has the proper store credentials by default after you passed the initial setup or used a system-user assertion to create a user.

root will not have access to that data by default and is usually completely disabled …

where does this image come from, how was it created and did you pass the first-start configuration without any errors ?

there are no Ubuntu Core images at all with 14.04. the first time Ubuntu Core images existed as pre-releases was in 2015 and the official Ubuntu Core release is based on 16.04, i have the impression you are simply using an ubuntu server minimal armhf image which has no relation to Ubuntu Core at all (Ubuntu core is exclusively built from snap packages, no apt, no deb support, readonly rootfs, extreme security confinement of all applications and server processes, completely different design to Ubuntu Server/Desktop)

That said, there exists a snapd package for 14.04 (using a systemd shim setup that fakes the systemd bits) but i do not think that has been tried much on armhf installs.

You can open bugs about this in launchpad to get the bugs with snapd on 14.04 server fixed (but keep in mind that 14.04 goes EOL in april)


Ubuntu server was mentioned at start.of thread so read carefully.

CORE 16 has a separate set of problems on armhf and OPiZ that I lead me to drop it. That includes two failure modes, either dropping IP address after update or falling into perpetual lan configuration prompts after update.


snapd package for 14.04 is the one that I installed onto Ubuntu Server for OPiZ and is the one that is broken.

If OPiZ is only offering 14.04 image, Ubuntu is dropping 14.04 and CORE 16 for OPiZ has all the problems I have reported then it does not look good for any marriage between Ubuntu and Orange Pi.


read slowly.

Ubuntu Server.

there is no need to be that agressive, i’m just trying to help, i’m sorry for overseeing the mentioning of ubuntu server at the top …


Yep, so CORE 16 is fragging OPiZ boards (see my other post), debian server for OPiZ can’t install snapd, ubuntu server for OPiZ installs snapd but can’t run snapd.

Looks like I won’t be needing to learn about snap after all.

Thanks anyway, I will go back to hand building.

Aggressive, really? I am just so many pixels dancing across your screen.

Perhaps you were aggressive in assuming I was aggressive.

This is otherwise a Turing Test yes.

Did you pass?

Well, i’m spending my spare time on a saturday trying to help you as one of the Ubuntu Core maintainers … and eventually to hopefully fix the issues you are seeing with the OPZ Ubuntu core image (that are obviously related to that hardware, its kernel or gadget configuration) so others do not run into them in the future and you can eventually have a working setup.

Attacking someone for making a mistake while trying to help you isnt really encouraging said person to actually keep helping you, don’t you think ?

Attacking! Aggressive! your inner monkey man needs work.