Snapd can find the snap, but cannot show info or install it. Why?


I’m experiencing strange error: snapd can find the snap, but it cannot install it - I get error that snap is not available. Here is output from console:

root@host:~# uname -a
Linux host 5.10.0-9-amd64 #1 SMP Debian 5.10.70-1 (2021-09-30) x86_64 GNU/Linux
root@host:/home/user# snap find wickrme
Name     Version  Publisher  Notes  Summary
wickrme  5.92.6   wickrinc   -      Secure Messaging for Teams
root@host:/home/user# snap install wickrme
error: snap "wickrme" not found
root@host:/home/user# snap info wickrme
error: no snap found for "wickrme"
root@host:/home/user# snap install wickrme --edge
error: snap "wickrme" not found
root@host:/home/user# snap install wickrme --beta
error: snap "wickrme" not found

I have tried to install snap-store and install snap from there, but I got error “Unable to install “Wickr Me”: snap not found”

Maybe there was some kind of transient server issue? I just tried now and I was able to start downloading it with

$ snap install wickrme

And I first confirmed it was found in the store with

$ snap info wickrme
name:      wickrme
summary:   Secure Messaging for Teams
publisher: Wickr Inc (wickrinc)
license:   unset
description: |
  Wickr Secure Messaging
snap-id: R08utvHDvWIykWvr4IfNMgFDIkfzJ72x
  latest/stable:    5.92.6  2021-11-18 (606) 472MB -
  latest/candidate: 5.73.13 2021-05-14 (477) 470MB -
  latest/beta:      5.90.3  2021-10-14 (586) 472MB -
  latest/edge:      5.92.6  2021-11-16 (606) 472MB -

Had similar issue, some time ago, with freecad . Turned out to be a store issue, but let me explain better.

It seems freecad Snap author decided on not allowing distribution to some territories (there’s a setting for this on the store) and, although I had been able to install FreeCAD earlier, I changed ISP and it turned out that IP ranges on this new provider weren’t mapped inside store, and so, I was unable to download it again (exactly same symptoms). See this thread. If that seems the case, maybe Daniel (@ roadmr) can help you, as he did to me.

1 Like

Unfortunately, I still have same issue…

Where are you located? See this from above:

In that case it would be good to get some error message or warning from snapd…