Snapd 2.37 breaks existing snap installation


#22

Thanks for this problem report and sorry for the trouble. We think this will be fixed once https://github.com/snapcore/snapd/pull/6473 lands (which should happen today).


#23

The fix for this is now in the “core” snap in the beta channel. Once it passed our QA it will be released to the candidate channel (and eventually stable).


#24

I cannot launch notepad-plus-plus… getting
cannot perform operation: mount --rbind /var/tmp /tmp/snap.rootfs_8bmcBE//var/tmp: Permission denied
I thought this was from the following security hardening I had done…

Let’s create a 1GB (or what is best for you) filesystem file for the /tmp parition.

sudo fallocate -l 1G /tmpdisk
sudo mkfs.ext4 /tmpdisk
sudo chmod 0600 /tmpdisk

Mount the new /tmp partition and set the right permissions.

sudo mount -o loop,noexec,nosuid,rw /tmpdisk /tmp
sudo chmod 1777 /tmp

Set the /tmp in the fstab.

sudo nano /etc/fstab
: /tmpdisk /tmp ext4 loop,nosuid,noexec,rw 0 0
sudo mount -o remount /tmp

Secure /var/tmp.

sudo mv /var/tmp /var/tmpold
sudo ln -s /tmp /var/tmp
sudo cp -prf /var/tmpold/* /tmp/
sudo rm -rf /var/tmpold/

Can’t say this is the reason however, I see a lot of people are running into the same issue so I’ll keep an open mind. I ran snap refresh --candidate core and installed notepad-plus-plus from there and still get the same error message when trying to load. This time

cannot perform operation: mount --rbind /var/tmp /tmp/snap.rootfs_gtO0J2//var/tmp: Permission denied


#25

Updated; tested on a separate ubuntu vm, everything installed fine; but after securing temp folders according to the template above it breaks snap installations the same.