Snapcraft push error


Today, I tried to push my application’s latest version snap. It loaded a lot and then I got this message in the terminal:

Did I do something wrong (by the way the push was slow yesterday also) or is this a server problem? I tried twice the push method, but it didn’t worked. The online dashboard show me messages about the rejected versions. How can I solve this problem?

I just get this message in the fail section on dashboard:
Extracting the package failed: { “runtime-errors”: { “error”: { “msg”: { “manual_review”: true, “text”: “unsquashfs -lls ‘/tmp/tmpZ39Ebi/package.snap’ failed: Read on filesystem failed because EOF\nread_uids_guids: failed to read id index table\nFATAL ERROR:failed to uid/gid table\nParallel unsquashfs: Using 4 processors\n” } }, “info”: {}, “warn”: {} } } Is a valid package

No, similar things have been happening to me on the store, although they may be resolved, now. @noise @roadmr is that accurate?


I noticed this when you posted on another thread, then kicked your snap and it should now be releasable. Let me know if this is not the case.

@kyrofa things aren’t entirely back to normal yet :frowning: we appreciate your patience while we work on a fix for the issues which we’ve already identified. We’ll update when all is back to normal!

@roadmr is all green, worth having something there?

Also, the last comment on Snap Store partial outage: slow uploads/downloads - round 2 says everything is good.

We do; scroll further down and you’ll see:

Incident History
Mar 28, 2018 8:26 PM Snap Store partial outage: slow uploads/downloads problems We have received more reports of slow downloads, uploads, failure to release. This is related to the outage the store experienced yesterday. We are aware of the situation and know the underlying causes, and are working to mitigate/solve the issue.

The green dots mainly tell if portions of the service are entirely down, I don’t think they’re subtle enough to tell when things are slow/sluggish which is the case now. This is why we resorted to posting a textual update. Unfortunately, I must admit our status page provider has a bug where the updates take a while to be published :frowning: (when it rains)…

1 Like

It’s definitely not. Let me update that.

That typically indicates something historical, i.e. in the past. This is an active thing, no? Not to mention, you need to scroll to see that, so it’s easy to miss.

The legend shows three possibilities: up, down, and service interruption. It sort of feels like the latter would work, here. There needs to be something obvious, near the top, that says “Hey, there are issues right now (not in the past) and we know about them.” My opinion, anyway.

Yeah! Thanks the release is working! Thank you again! :slight_smile: