Snap wont install..... fedora 34 workstation

appalogize… tried searching. was at a loss for what to search for beyond below error… and searching by that found nothing. Feel free to point me to existing thread so not to repeat oneself.

trying to install snap so I can install a specific downloader. first step worked. ( sudo dnf install snapd) rebooted…

then did second step ( sudo ln -s /var/lib/snapd/snap /snap ) and got an error of

too early for operation, device not yet seeded or device model not acknowledged

any suggestions on what issue is and how to fix

When snapd starts for the first time, it does some internal set up steps, eg. generates encryption keys and so on. Normally this should finish very quickly, but obviously depends on the speed of the host machine.

However, sudo ln -s /var/lib/snapd/snap /snap does not make a call to snapd, so I’m not sure how you got that error message. I’m guessing that you tried to install a snap after you’ve ran the ln -s .. command. In which case, it should be enough to retry the install command. If you still see the error, please attach the output of snap changes command.