Snap version of Gimp won't install

I am not a frequent user of Gimp. This morning I tried to use my Gimp snap and it would not provide me with access to any Help documentation, either internally or online. I was required to install some kind of add-on but I didn’t understand the message so I could not proceed. So I uninstalled the snap and used Gimp from the Ubuntu store. However, I am left feeling unhappy that, first, I cannot use the Gimp snap, and, second, the store version is an older version than the snap version.
I just tried to reinstall the snap and I was informed that I didn’t have “invalid credentials”. (I am the sudo, so why not?). I just tried again and got a different error message: snap “gimp” not found.
I am dazed and confused. Can anyone help, please?

Sorry to hear you’re having trouble here. Can you please paste the output of the following commands - wrap them in 3 backticks so they format nicely if you don’t mind :slight_smile:

snap version

snap changes

snap install gimp

That will help us debug.

with regard to the documentation, I’ve been struggling to get webkit2gtk working or successfully compiling. The webkit renderer is required for viewing the documentation, unfortunately :frowning:

“snap 2.35.1
snapd 2.35.1
series 16
ubuntu 16.04
kernel 4.15.0-33-generic”

“ID Status Spawn Ready Summary
497 Done today at 12:38 PDT today at 12:39 PDT Remove “gimp” snap
498 Error today at 12:43 PDT today at 12:43 PDT Install “gimp” snap
499 Error today at 14:52 PDT today at 14:52 PDT Install “gimp” snap
500 Error today at 14:53 PDT today at 14:53 PDT Install “gimp” snap
501 Error today at 14:53 PDT today at 14:53 PDT Install “gimp” snap
502 Error today at 14:53 PDT today at 14:53 PDT Install “gimp” snap
503 Error today at 14:58 PDT today at 14:58 PDT Install “gimp” snap
504 Error today at 15:03 PDT today at 15:03 PDT Install “gimp” snap
505 Error today at 15:04 PDT today at 15:04 PDT Install “gimp” snap
506 Done today at 15:29 PDT today at 15:30 PDT Auto-refresh snap “anbox”
507 Error today at 15:32 PDT today at 15:32 PDT Install “gimp” snap
508 Error today at 15:37 PDT today at 15:37 PDT Install “gimp” snap”

"error: cannot perform the following tasks:

  • Download snap “gimp” (47) from channel “stable” (invalid credentials)"

Thanks for confirmation of root cause.