Snap Kdenlive cannot run in classic

I’m quite new to linux as a desktop. I switched to it few months ago. At first, I had poroblem with flatpack and snap (couldn’t use user folders in them). Then I found magic ‘–classic’ command which made those program access everything fine.

I spent half day trying to make a movie on kdenlive, and guess what? Kdenlive was not installed with classic, because i did not notice notification, that classic is ignored for strictly confined snap. So I lost few hours of my work.

I want to save my files where I want… I’m seriously starting to think about returning to windows… linux is fun, but all those snap problems with files are most frustrating.

Would be glad if someone could point in direction, how to setup snap so it can access home/user/Videos

I hope you know what I mean. Working whole day on a movie, then not being able to save it to disk.

Welcome. Two things. Firstly, users shouldn’t try and force non-classic snaps to run in classic “mode”. It just won’t work right. Classic and non-classic snaps are built fundamentally differently, it’s not just a flag you turn on/off at install time I’m afraid.

Secondly, by default, the Kdenlive snap has access to home which means it should be able to write to /home/user/Videos/ just fine. It also has removable-media auto-connected which means it can write to mounted USB keys and hard disks too.

So I don’t quite understand why, on a normal install, it wouldn’t be able to write there.

Hello popey, thanks for response!

I can open folder, navigate to Videos. Type name of a file and click “Open” (strange it’s not “Save”).

I’m in good folder etc. Everything seems fine. I click Save, and when I go to “Open recent” path is completly different. “/run/user/1000/doc/{hash}/myfilenam.kdenlive”. So I get magically redirected somewhere else.

I can, however, open files from Videos folder (made with apt installed kden v 17) normally. I’m kinda frustrated atm that all my work went to /dev/null :expressionless:

Does your Video folder sit on the same partition as your system ?

Differently worded : is your /home/$USER/Videos inside the root of your system / or is it a separate partition, or on another disk ?

As @popey mentioned, if your personal folders and files are not on the same partition as snap, then you should grant your kdenlive-as-a-snap permission to access removable-media which actually means access to anything under /media, /mnt and /run/mnt.

You can do that through « software », installed tab, on the kdenlive page you’ll find a « permissions » button on top. If you’re on Ubuntu 20.04 ( or anything with gnome DE ) you’ll find in « settings » a section for « applications » where you can manage permissions.

Yeah it’s a real pity snap app’s don’t invite user to take care of these permissions at first launch… It would avoid these kinds of bad surprise.

Be aware that a snap-app will never access anything straight on / nor any hidden files/folders.
Granted the right permissions are set, it will only have access to /home, /media, /mnt and /run/mnt. Nowhere else.

Hello @Coeur-Noir. Thanks for answear

I’m on mint 19.

Here is dump of df

udev             16G     0   16G   0% /dev
tmpfs           3,2G  3,7M  3,2G   1% /run
/dev/sdd2       418G  251G  146G  64% /
tmpfs            16G  256M   16G   2% /dev/shm
tmpfs           5,0M  4,0K  5,0M   1% /run/lock
tmpfs            16G     0   16G   0% /sys/fs/cgroup
/dev/loop1       55M   55M     0 100% /snap/gtk-common-themes/1502
/dev/loop0      333M  333M     0 100% /snap/xx/158
/dev/loop2      143M  143M     0 100% /snap/slack/23
/dev/loop3      116M  116M     0 100% /snap/screencloud/3
/dev/loop4      162M  162M     0 100% /snap/gnome-3-28-1804/128
/dev/loop5       55M   55M     0 100% /snap/core18/1705
/dev/loop6      140M  140M     0 100% /snap/slack/24
/dev/loop7       88M   88M     0 100% /snap/kdenlive/24
/dev/loop8      236M  236M     0 100% /snap/kde-frameworks-5/27
/dev/loop9       63M   63M     0 100% /snap/gtk-common-themes/1506
/dev/loop10     333M  333M     0 100% /snap/xx/162
/dev/loop11     291M  291M     0 100% /snap/kde-frameworks-5-qt-5-14-core18/4
/dev/loop12      98M   98M     0 100% /snap/core/9289
/dev/loop13      55M   55M     0 100% /snap/core18/1754
/dev/loop15     159M  159M     0 100% /snap/xx/157
/dev/loop14     161M  161M     0 100% /snap/gnome-3-28-1804/116
/dev/loop16     142M  142M     0 100% /snap/inkscape/7627
/dev/loop17     159M  159M     0 100% /snap/xx/156
/dev/loop18      97M   97M     0 100% /snap/core/9436
/dev/nvme0n1p2   96M   31M   66M  33% /boot/efi
tmpfs           3,2G   60K  3,2G   1% /run/user/1000

It’s strange, because other programs seem to run fine and have access to home folder.

Snap list shows

inkscape                         1.0-6e3e5246a0-2020-05-07   7627  latest/stable  inkscape✓   
kdenlive                         20.04.0                     24    latest/stable  kde✓        -

But inkscape can write just fine.

Mmm… let’s see
snap connections kdenlive
amongst other interfaces, I expect to find there : desktop, home, removable-media

@Coeur-Noir

Interface                                     Plug                            Slot                                                                  Notes
content[kde-frameworks-5-qt-5-14-core18-all]  kdenlive:kde-frameworks-5-plug  kde-frameworks-5-qt-5-14-core18:kde-frameworks-5-qt-5-14-core18-slot  -
dbus                                          -                               kdenlive:session-dbus-interface                                       -
desktop                                       kdenlive:desktop                :desktop                                                              -
desktop-legacy                                kdenlive:desktop-legacy         :desktop-legacy                                                       -
home                                          kdenlive:home                   :home                                                                 -
network                                       kdenlive:network                :network                                                              -
network-bind                                  kdenlive:network-bind           :network-bind                                                         -
opengl                                        kdenlive:opengl                 :opengl                                                               -
pulseaudio                                    kdenlive:pulseaudio             :pulseaudio                                                           -
removable-media                               kdenlive:removable-media        :removable-media                                                      -
unity7                                        kdenlive:unity7                 :unity7                                                               -
x11                                           kdenlive:x11                    :x11                                                                  -

Looks like an issue with kdenlive, xdg-document-portal and bad design choice to use that folder for documents.

When opening and saving click on location bar and then enter /home/yourname/Videos. Recent and Search For are not working correctly because of mentioned issue.

Or…
should you install xdg-desktop-portal and xdg-desktop-portal-gtk on your system ?

given it is a KDE app perhaps rather

xdg-desktop-portal-kde

:wink:

Indeed !

A real question here is : if those portals are often needed by snap ( and flatpak ) app’s why aren’t those installed by default as soon as snap or flatpak are enabled ???

Another trick only geek-dev-iT people may assume, but normal people just won’t know.

If this solves @gacekssj4’s problem. It’s just a bet for now.

sudo apt install xdg-desktop-portal-kde xdg-desktop-portal-gtk xdg-desktop-portal

@predr’s comment is interesting too !
Kdenlive is Qt based, and run on linux mint 19 here : on which DE ? cinnamon ?

@Coeur-Noir Yes, Cinnamon :slight_smile:
I installed those, and still nothing. It does not save to /home/user/Videos and to this /run/user/1000/doc/{hash}/myfilenam.kdenlive file.

@predr So it’s KDENLive’s implementation fault?

I partially solved my problem. I never used appimages and downloaded it from their site. It works just fine.
Would be cool if snap worked tho… so can test any ideas if you will have any :slight_smile:

Also… there is slight difference between saving on appimage and on snap package.


(could only put 1 image in post, had to double screen)

So i think @predr may be right it’s something wrong with kdenlive snap package?

Here is the issue I mentioned. Maybe someone with complete understanding of xdg-desktop-portal can explain what is going on.

So it’s KDENLive’s implementation fault?

@gacekssj4 Their snap implementation could be better, detect when it’s running as snap and offer better choices selecting files/directories. I also noticed import/export project doesn’t work. But I don’t think this is their fault.

Ok. Thank you @predr and @Coeur-Noir and everyone for your help. I will stick with .appimage for now then. It works fine (except i have to start it from command line).

And lol, another great success story for snap…


…or click on the « disk » icon in the address bar and from there, browse to your
/home/your_name/Videos folder ???

Next time you open that save-as dialog, it should remain on the last used path.

Anyway it seems Kdenlive team recommends PPA or AppImage - not snap neither flatpak.
https://kdenlive.org/fr/telechargements/

I’m not liking xdg-desktop-portal so far.

  1. When it fails to handle file access it looks like it is snap’s fault because of transparent nature of it.

  2. Developers are apparently too lazy to check if they already have access to files before using it and just use it for everything.

  3. File access goes trough /run/user/1000/…/doc and contents is deleted when user logs off.

Combine 2 and 3 and every bug in xdg-desktop-portal is a potential file loss.

@gacekssj4 :vulcan_salute: Only download from official project site.

Ok thanks @predr now I understand why those « portals » are not installed by default.
Looks like they are not the best way to « deal with » file access.

Maybe reporting to https://bugs.kde.org/enter_bug.cgi → I thought KDE was moving to GitLab ?

Doing it :slight_smile: I really like snap idea (like docker) but being forced to use snap is not something i like. Sometimes i need to use editor to edit - for example /etc/httpd.conf. There may be problems with snap then from what I understand. I understand it’s easier to contain them and have all dependencies solved instead of relying on system ones. It’s a great compatibility feature at loss of liberty ;(

being forced to use snap is not something i like

What?

i need to use editor to edit - for example /etc/httpd.conf

Developer tools (including code editors) are classic snaps with full access to system.

There may be problems with snap then from what I understand

Strict (isolated) snaps are only granted access to files they need. For example, there is no reason for a video editing app to see my servers but it needs to see my graphics.

it’s easier to contain them and have all dependencies solved instead of relying on system ones

Dependency management and clean local environment are just a bonus for me. Main feature for me is security. Epic stole friends list from Steam because it had access to those files. I’m not willing to blindly trust apps with my AWS credentials, SSH keys, Contacts etc.

great compatibility feature at loss of liberty

Are you saying running everything as root is the most liberal (free from any constrains) thing to do? Or did you mean something else.