Snap Install Microk8s Error

i moved that to so it gets more readable (no linewraps etc)

where does docker come into the picture?

The server uses Nvidia-Docker for Deep Learning Packages for research and we wanted microk8s as we wanted to install kubeflow to help job schedule the use of our GPU since it will be heavily used server for research

The docker comes into the picture because the /proc/self/mountinfo will list all of the mount points

Ah, phew. For a moment I was worried about how deep we were nesting the containers … :slight_smile:

What’s the output of snap list?

Currently my snap list output is

Name          Version               Rev   Tracking  Publisher   Notes
core          16-2.41               7713  stable    canonical✓  core
core18        20190904              1144  stable    canonical✓  base
hello-world   6.4                   29    stable    canonical✓  -
snappy-debug  0.34-snapd2.39.3+git  414   stable    canonical✓  devmode

It originally came with just core but I installed core18, snappy-debug, and hello-world recently.

and now, with core and core18 already installed, installing microk8s fails with the same error?

Yes same error message. I just checked my /snap/core directory and it only has 7396 and 7713 but not a directory called current, which all of my other 18.04 machines have. Could that be the issue?

something really whack is going on with this system: if there were no current in /snap/core, snap list should say broken in the Notes column.

What happens if you sudo apt purge snapd and then sudo apt install snapd and start over?

Haha! That actually fixed the issue. I just installed microk8s.


Excellent. Where did you get the image you started from? Suspecting seed.yaml is broken in there and we need to alert people about it

1 Like

What do you mean by image I started from?

how did you install that server, where did the installation image come from ?

Oh I installed it fresh from Ubuntu website but I got the docker and everything from AMAX (third party source) to install onto the computer. Could be somewhere during that process it messed things up?