Slack snap - window has no icon

I just installed Ubuntu 18.04 and decided to install Slack via deb, which turns out to uninstall my version of virtualbox and other necessary packages. So I uninstalled the deb, and installed with snap. I don’t have an icon on the tray, but I do see an icon on the dock and in the app switcher.
I’ve rebooted but no change. I’ve read every post here, but it seems there’s no workaround to fix the tray icon. Does anybody know how to fix this?

EDIT: The problem was not Slack but TopIcons Plus, I decided to switch to Appindicator extension and now the icon is working.

Ubuntu 16.04, icon still missing from launcher and application switcher (alt+tab)

I’ve just added StartupWMClass=Slack to /var/lib/snapd/desktop/applications/slack_slack.desktop and it has fixed the problem!

Confirm that this fixes the problem.

1 Like

Hi gionn - reading through the thread, other commenters said that slack fixed it in release 3.1.0 so I’m curious what version of Slack you are using and what desktop environment and/or window manager you might be using.

Ubuntu 18.10, Plasma 5.14. Issue still exist :persevere:
Screenshot_20181218_154150

Same problem with Manjaro 18, Xfce GTK3 4.13, snapd 2.35.5, and slack 3.3.3-9.

This continues to be a problem because Slack does not provide an icon using the NET_WM_ICON property.

1 Like

Fedora 29, It worked for me

Linux Mint 19.1, Cinnamon desktop, still has no icon.
I already tried to add StartupWMClass=Slack to the desktop file.

I am on Ubuntu 18.10, running XFCE. My indicator icon was showing the Slacktothorpe properly, but the window list displayed the default fallback icon.

As a workaround, Paul Evans’ xseticon may be used to change the icon of an already-running Slack instance. This seems to work even after closing the window and reopening it from the tray/indicator.

  1. Clone https://github.com/xeyownt/xseticon
  2. Install dependencies
    sudo apt install libxmu-headers libgd-dev libxmu-dev
    
  3. Do the make dance
    make
    
  4. Install the binary somewhere on your $PATH
    sudo cp xseticon /usr/local/bin
    
  5. With the Slack window visible, execute the following, which will provide crosshairs to select the Slack window
    xseticon /snap/slack/9/usr/share/pixmaps/slack.png
    
  6. bada bing, bada boom
1 Like

Hi,
I have the same problem with the last version:
Slack: 3.3.4
Snap: 2.36.3-1
Xfce4: 4.12

Linux Mint 19.1, Cinnamon desktop, still has no icon.
StartupWMClass=Slack didn’t help
Is there a workaround?

I was having this issue on Debian 9 (Stretch), adding the StartupWMClass=Slack line to the .desktop file solved it for me.

Can confirm that the desktop file mod fixes it in ubuntu 18.10 as well.

It still isn’t setting an EWMH icon. However, as of 3.4.0, Slack sets _NET_WM_WINDOW_TYPE = _NET_WM_WINDOW_TYPE_MAIN. This causes Slack to be left out of the alt-tab menu. _NET_WM_WINDOW_TYPE_MAIN is not defined in the EWMH spec and has no results on a Google search.

https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/1827302

Note that the xseticon utility is now packaged as a snap:

Worked for me too! Thanks. It should be somehow added to the app because any update removes this change.

Linux Mint 19 with Cinnamon desktop, still has no icon. StartupWMClass=Slack didn’t help me too. :frowning_face:

Linux Mint still misses the tray icon, but only with the snap version.

Same issue on Solus Budgie. Task icon is visible, but no tray icon. If I close the Slack window (close to tray enabled in Slack settings), then there’s no way to restore it other than relaunching Slack.

I’m using xubuntu 18.04 and for me both icons are missing. task bar and notification indicator.
found this solution from manjaro forum, and it works https://flathub.org/apps/details/com.slack.Slack

image