Slack crashes on Debian

Executing slack on the terminal emulator does not produce any output nor start Slack. The only thing is the following Syslog record:

out 15 16:58:36 galadriel kernel: traps: slack[15792] trap int3 ip:5631583631a5 sp:7fff019e0850 error:0 in slack[5631563e6000+531d000]

What I’ve done

  • Reinstall slack
  • Delete ~/.config/Slack
  • Installed slack.deb, which worked

Aditional information

 ~$ snap info slack
name:      slack
summary:   Team communication for the 21st century.
publisher: Slack✓
license:   unset
description: |
  Caution: Slack for Linux is in beta. We’re still busy adding features and ironing out potential

  Slack brings team communication and collaboration into one place so you can get more work done,
  whether you belong to a large enterprise or a small business. Check off your to-do list and move
  your projects forward by bringing the right people, conversations, tools, and information you need
  together. Slack is available on any device, so you can find and access your team and your work,
  whether you’re at your desk or on the go.

  Scientifically proven (or at least rumored) to make your working life simpler, more pleasant, and
  more productive. We hope you’ll give Slack a try.

  Stop by and learn more at:
  - slack
snap-id:      JUJH91Ved74jd4ZgJCpzMBtYbPOzTlsD
tracking:     stable
refresh-date: today at 11:23 -03
  stable:    4.1.1 2019-10-09 (18) 153MB classic
  candidate: ↑
  beta:      ↑
  edge:      3.3.1 2018-08-31  (8) 148MB classic
installed:   4.1.1            (18) 153MB classic
 ~$ uname -a
Linux galadriel 5.2.0-2-amd64 #1 SMP Debian 5.2.9-2 (2019-08-21) x86_64 GNU/Linux
 ~$ snap version
snap    2.42
snapd   2.42
series  16
debian  -
kernel  5.2.0-2-amd64
 ~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux bullseye/sid
Release:        testing/unstable
Codename:       n/a
1 Like

I also have the same issue since several days ago. I am using Debian 10.

perhaps the patch from

has not landed in the debian 5.2 kernel yet ? (there should be some debug hints to find if you are affected by this in the other thread)

As far as I can tell this issue is not related to Mounts broken with kernel 5.2. Besides that, I’ve other snaps using volumes:

~$ snap list
Name               Version                  Rev   Tracking  Publisher     Notes
0ad                0.0.23b-alpha            115   stable    osomon        -
atom               1.40.1                   238   stable    snapcrafters  classic
core               16-2.42                  7917  stable    canonical✓    core
core18             20191010                 1223  stable    canonical✓    base
discord            0.0.9                    93    stable    snapcrafters  -
gnome-3-26-1604          92    stable    canonical✓    -
gtk-common-themes  0.1-25-gcc83164          1353  stable    canonical✓    -
mailspring         1.7.1                    402   stable    foundry376✓   -
odrive             latest                   76    edge      bill-666      -
slack              4.1.1                    18    stable    slack✓        classic
spotify    36    stable    spotify✓      -

Facing same problem on debian 10 buster. Slack is simply not working with snap.
Tried to install slack using debian package it works but at the time of installation throwing an error for gconf2***

Uninstalled the latest version of slack
and then installed the edge (older - weird) version and guess what, its working fine.

Command to remove latest and greatest slack:
sudo snap remove slack

Command to install the edge version:
sudo snap install slack --classic --channel=edge

Hey guys I raised ticket on slack site about above issue and they have helped me to get it up and running.
It was really quick reply from Slack support team (Wojtek).

Wojtek confirmed that there is known bug in current version and it will be fixed in next release meanwhile slack’s latest snap package can be used using below command.

slack --no-sandbox

Sudhir Dhumal


Confirming that slack --no-sandbox did start Slack.