Shared-ros demo - ros-app cannot access roslaunch

I’d like to build apps on https://github.com/snapcore/snapcraft/tree/master/demos/shared-ros
Both snaps, ros-base and ros-app, build (on 16.04) and install (on Joule with tuchuck Ubuntu Core image).

vilvo@localhost:~$ snap install --devmode ros-base_1.0_amd64.snap
ros-base 1.0 installed
vilvo@localhost:~$ snap install --devmode ros-app_1.0_amd64.snap
ros-app 1.0 installed
vilvo@localhost:~$ snap interfaces|grep ros\-
:network                  pulseaudio,ros-app,snapweb
:network-bind             ros-app,snapweb
ros-base:ros-base         -
-                         ros-app:ros-base

Launching the ros-app fails to find roslaunch from ros-base:

vilvo@localhost:~$ ros-app.launch-project 
/snap/ros-app/x1/bin/run-system: line 29: roslaunch: command not found
vilvo@localhost:~$ find /snap/ros-base/ -iname roslaunch
find: '/snap/ros-base/x1/etc/ssl/private': Permission denied
/snap/ros-base/x1/opt/ros/kinetic/bin/roslaunch
/snap/ros-base/x1/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch
/snap/ros-base/x1/opt/ros/kinetic/share/roslaunch

Is this an issue with the interfaces between snaps or path in snapcraft demos?

ros-example_1.0_amd64.snap works fine but it would be great to share the ros-base between snaps.

The output of snap interfaces shows that the ros-base interface is not connected. Have you tried connecting them?

sudo snap connect ros-app:ros-base ros-base:ros-base

Then try running it again.

Thank you @kyrofa - works now. I thought I tried also connecting the snaps but apparently not.