Setting system refresh.timer = "managed" on boot


In the documention all i could find was setting this through command line.

sudo snap set system refresh.timer = managed

So i tried this as an install hooks and that does work as it cannot find system which is core20 in my case.

Where do i add this variable? is it in gadget?

Any help would be helpful :grin:

I tried adding it in gadget under defaults and i could see that refresh timer goes to managed when i run

snap get -d system

But it still automatically refreshes. Am i missing a step?

This could be a bug too

IIRC you can only set managed if there is at least one snap which has snapd-control interface. You can read more about the interface in the docs:

So, if there arent any snaps with snapd-control interface. It would automatically refresh even if i set it to managed?

A request to set refresh.timer=managed will be rejected, and yes it will keep refreshing automatically.

Thanks i will try it out

Thanks, it was not refreshing automatically when there is a snap with snapd-control interface