Set-version not working

In the JabRef snap, available at https://github.com/JabRef/jabref/blob/master/snap/snapcraft.yaml,
the builds have started to fail with the following error:

Failed to generate snap metadata: 'adopt-info' refers to part 'jabref', but that part is lacking the 'parse-info' property.

In the jabref part I use snapcraftctl set-version, and it worked up to now.
The build fails both locally and with remote-build

Your problem is the set-version you have is setting an empty string as the version so snapcraft is assuming that it failed. Your tar.gz file includes the JabRef.cfg that you’re attempting to parse, but that file does not include a line with the text app.version= which is the text you’re trying to match with grep so the whole command returns an empty string.

1 Like

*gulps* try seeing if you can do it in another coding website

I missed that completely…
Thanks @daniel

I tried changing the script to
snapcraftctl set-version "$(git describe --tags | cut -c2-)"
but I got the same error on a remote-build
(I cannot use the standard git version because it selects the incorrect value…)

Hey do you think its the coding your using

try it in Berkeley Snap or maybe even Code.org

This is the forum for the snapcraft tool to bundle and release packages on linux distros, not the block-based programming language

1 Like

oof,so i’d try on other website coding languages then

sorry for wasting your time

Fixed… the file structure in the tarfile changed.

good job!i’m glad you fixed your problem!

FWIW, I put up a PR to fix this case for future users: https://github.com/snapcore/snapcraft/pull/3325

2 Likes