Qmake plugin should be able to support different qt versions

This is more of a feature request, but

snapcraft uses the qt5-qmake which is based on Qt 5.5.1 for it’s qmake plugin

However, many Qt apps require a specific version of Qt in order to build their app.

Shouldn’t snapcraft support different Qt versions?

This is becoming repeatedly a problem and I end up pulling prebuilt applications to package each application into a snap which is not desirable.

Another alternative is to pull the version of Qt5 I want as a part and use it but I am not sure if this is a better practice.

1 Like