Qmake plugin should be able to select different minor qtversions

The current qmake plugin does not let you to change the version of Qt qmake is using.

Current qmake plugin implementation uses the qt5-qmake package which is Qt 5.5.1

        self.build_packages.append('make')
        if self.options.qt_version == 'qt5':
            self.build_packages.extend(['qt5-qmake', 'qtbase5-dev'])
        elif self.options.qt_version == 'qt4':
            self.build_packages.extend(['qt4-qmake', 'libqt4-dev'])
        else:
            raise RuntimeError('Unsupported Qt version: {!r}'.format(
                self.options.qt_version))

However, many applications require using special qt versions in order to build.