Python 3.5 still in python plugin? Update?

I’m trying to update a snapcraft recipe and one of the dependencies got bumped up (and understandably, I’d say) they require now Python 3.6 (or newer).

  • Python 3.5 has been deprecated and is not safe to use anymore.
Pulling edge-core-tool 
DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.

So, Python 3.5 should not really be used.

I updated the docker image to pull in the latest stable snapcraft, but that didn’t help.

FROM snapcore/snapcraft:stable

Iis it really so that a newer Python is not available readily?

How would one go about updating it manually then?

The snapcraft docker image has not been updated in 2 years, either. Is it abandonware?

It is frozen to what Ubuntu 16.04 was at the time, updating the image could break people that depend on this, since the Docker FROM needs to match your target base it has indeed been deprecated and moved to more of a self serving through documentation: https://snapcraft.io/docs/build-on-docker