Pushing new FreeCAD snap to the store


That snap is big (about 500MB) and I am facing issues this morning to update it. I need to do it because I faced some challenges with the new fontconfig in 20.04 which broke the previous release. (the issue was on my side ;))

Any help appreciated because I can’t do that much with the 502 error coming from the server


Pushing freecad_0.18_amd64.snap
After pushing, an attempt will be made to release to ‘edge’
Preparing to push ‘/home/vagrant/Results/freecad_0.18_amd64.snap’ to the store.
The Snap Store encountered an error while processing your request: bad gateway (code 502).======================================== ] 99%
The operational status of the Snap Store can be checked at https://status.snapcraft.io/

Hi, sorry for the problem with your upload. We were doing a release of the upload service this morning and it’s possible it got caught in the transition. Can you please retry and let us know if you continue to see failures?

Also, that is indeed a fairly large snap, have you attempted to slim it down? Folks in the #snapcraft channel may have some advice on that front.

Same issue. It will be tough to reduce the filesize, the snap is building a full 3D CAD parametric application which is getting a lot of dependencies … I tried to keep it as small as I could up to now, but with the switch to 20.04, I had to embed some additionnal stuff to make it work from Xenial to latest ubuntu release. Will appreciate if we could find a way to make work that upload :wink:

Look like that the push works perfectly. The issue stand within the stuff which is happening in the background later. Still get the bad gateway

Hi vejame.

We’re having a bit of difficulty tracking this issue down.

Could you please try again? But this time, separating out the upload from the release, and using the --debug flag, and with some timestamp info?

e.g, something like these commands and their output would be useful:

snapcraft --debug upload freecad_0.18_amd64.snap
snapcraft --debug release freecad [revision] edge


I will give it a try in a few minutes. Thanks for your answer. Fingers crossed

Look like that it works tonight. Don’t know what happened this morning. Thanks for your help !

Ah, good.

I suspect you unluckily hit the 2 short (5m) windows yesterday when we were testing some new code paths. We’ve identified that issue and are fixing, so hopefully this won’t happen again.


1 Like