Non-x86 Archs Will not Build


#1

Hey guys,

I’m trying to utilize build.snapcraft.io with a personal project.

I have a reasonably straight forward pip that I wish to install. But it seems to not be able to install the jq & typed-ast pip packages (used heavily in my application) on armhf, arm64, ppc63el or s390x. I was hoping that you guys might have some recommendations on how to fix these issues as they seem to be architecture specific.

Thanks


#2

The build failed on the wheel building of the typed-ast package, you should contact it’s developers for support or find an alternative to replace it.

Also you may consider disable the publishing on the offending architectures by using the architectures property.


#3

Lin,

Do you know if there’s a way to use multipass to spin up the same arm environment used to build so I can make a good bug report to typed-ast?

CRH


#4

@Lin-Buo-Ren So I spun up a raspbian image on my raspberry pi. And I tried to test to see if typed-ast would pip install. It did perfectly. I’m not sure how to replicate. I seem to only be able to replicate the issue in snapcraft.


#5

A few questions about where it worked:

  • Is it the same python major and minor version?
  • Did you build with the same CFLAGS?
  • Are you using the same compiler and version?

#6

@sergiusens TBH I’m not sure. What I would like to do is spin up (ideally using multipass but optionally on a raspberry pi) the same arm build environment that is used on build.snapcraft.io so that I can test that. My instinct tells me that if it works in raspbian but not in the in the ci/cd pipeline that it’s possible that I’m just missing a package of some sort.


#7

I think you’d be closer to b.s.io if you went with ubuntu server (16.04 or 18.04 depending on your base) rather than raspbian on the pi :slight_smile:


#8

Is that via a different image than the Ubuntu Core one?


#9

ubuntu core is completely assembled from snaps and does not support deb packages in any way … that said … you can indeed install the lxd snap on it (or docker) and run a container with a classic ubuntu install to do your builds in (in fact i have been tinkering with a pre-made appliance image doing exactly that but do not have anything ready enough to release yet)


#10

Okay I’ll have to do some more tinkering. If you have examples @ogra I’d love to see them though.

THanks!