Mysql-workbench wont start suddenly - ubuntu 22

After a recent packages update I noticed that mysql-workbench is not running on my ubuntu22 . When clicking the mysql-workbench icon if searching in “activities” nothing happens. On the command line

$ snap run mysql-workbench-community 
/snap/mysql-workbench-community/10/snap/command-chain/desktop-launch: line 52: /home/bizmate/.config/user-dirs.dirs: Permission denied
sed: can't read /home/bizmate/.config/user-dirs.dirs: Permission denied
/snap/mysql-workbench-community/10/snap/command-chain/desktop-launch: line 261: /home/bizmate/.config/user-dirs.dirs: Permission denied
cp: cannot open '/home/bizmate/.config/user-dirs.locale' for reading: Permission denied
/snap/mysql-workbench-community/10/snap/command-chain/desktop-launch: line 266: /home/bizmate/.config/user-dirs.locale: Permission denied
cp: cannot stat '/snap/mysql-workbench-community/10/gnome-platform/usr/share/mime': No such file or directory
Directory '/home/bizmate/snap/mysql-workbench-community/10/.local/share/mime/packages' does not exist!
/snap/mysql-workbench-community/10/snap/command-chain/desktop-launch: line 20: /snap/mysql-workbench-community/10/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0: No such file or directory
ERROR: update-mime-database /home/bizmate/snap/mysql-workbench-community/10/.local/share/mime exited abnormally with status 1
ERROR: /snap/mysql-workbench-community/10/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 exited abnormally with status 127
Using /snap/mysql-workbench-community/10/usr/lib/x86_64-linux-gnu/

(process:10771): Gtk-WARNING **: 04:41:42.263: Locale not supported by C library.
	Using the fallback 'C' locale.
Gtk-Message: 04:41:42.263: Failed to load module "xapp-gtk3-module"
Gtk-Message: 04:41:42.263: Failed to load module "canberra-gtk-module"
Gtk-Message: 04:41:42.263: Failed to load module "canberra-gtk-module"

(mysql-workbench-bin:10771): Gtk-WARNING **: 04:41:42.264: cannot open display: :1

I have other problems with snap based packages that just wont work but this is critical so I might actually remove it from snap and install from deb if unable to get to a good conclusion.

I tried to google the error " Locale not supported by C library" and tried to reinstall locales but this made no difference.

That file

$ ls -la /home/bizmate/.config/user-dirs.dirs
-rw------- 1 bizmate bizmate 632 Nov 12  2011 /home/bizmate/.config/user-dirs.dirs

has not been touched since 2011 so I am really not sure why it cannot be read now given that my user has read permissions.

Same for this locales file

$ ls -la /home/bizmate/.config/user-dirs.locale
-rw-rw-r-- 1 bizmate bizmate 5 Nov 12  2011 /home/bizmate/.config/user-dirs.locale

If i try to refresh snap says there are no upgrades.

$ sudo snap refresh mysql-workbench-community
snap "mysql-workbench-community" has no available updates

I also had the great idea to remove it and install it again. This worked but I lost all configuration and it rather frustrating.

Any chance I can recover this configuration from somewhere?

I am also getting an annoying AppArmor policy problem after re-installingmysql_workbench_snap-AppArmor2022-10-25 05-47-45

I will try with an apt repo as this is really bad and breaking my system

I managed to get mysql workbench to work again, all connections also back as I think this method can access the config files it had created before.

Just remove the snap one if you have similar problems and install the version matching your system available directly from Oracle at

Good luck

looks like the snap uses (or should use) the password-manager-service interface which is either not added to the snap or has not been connected by you after installing it …

did you (or could you) report it to the packager so it can be fixed ? the bug url/developer website pointed to by the snap is:

the developer should probably ask for auto-connection or add info the the snap description so users know this connection is required.

Snap author here, but i’m not affiliated with Oracle. To access Keyring you need to connect password-manager-service because this interface don’t have Auto Connect. For some reason this explanations are gone from Snap Store. I updated the documentation to match with Readme of github.

If you use connections, Workbench use Password Manager and ssh to work properly.

So it is necessary to give this permission explicitly.

snap connect mysql-workbench-community:password-manager-service 
snap connect mysql-workbench-community:ssh-keys

Or if you use files on external disks or need to print files, too.

snap connect mysql-workbench-community:cups-control
snap connect mysql-workbench-community:removable-media

You need do snap connect mysql-workbench-community:password-manager-service otherwise you get a AppArmor error when connecting

Thank you for the reply. Not sure what the standards are in this case on the Snap side but when installing the deb packages none of these dependencies need to be explicitly handled manually.

Any reasons why Snap dependencies cannot be specified and thus handled without the user warring about them?

for security reasons snaps are fully self contained (i.e. they need to ship all dependencies inside) and have no access to the host system at all … that way strict snaps do not need to be reviewed, they are secure on a level that we can trust the system over the uploader so that you do not have a bottleneck where humans need to review each and every upload (like it is with i.e. deb packages)

to allow a snapped app to access select system resources anyway, snaps have an interface system that allow very particular system bits to be accessed … some of these interfaces are rather harmless and thus get auto-connected at install time of a snap (i.e. the network or home interfaces) … other interfaces that allow access to critical pieces of your system (like a password manager that holds all your passwords) will need consent from you as a user or gain trust through a requested “review for auto connection” … this is why you have to manually connect such interfaces, it is for your security.

that said, snap developers can always request a review for a possible auto-connection of such privileged interfaces for their snaps here in the store-requests category, @toninbolzan could surely do this too for the mysql-workbench snap …