Minecraft 2.1.1218 not working on Ubuntu 18.04

We had minecraft launcher installed on our Ubunto for quite some time.
The latest update to the launcher, which was done on 7/23/18 or 7/24/18 caused the launcher to stop working. We click on the icon, but no screen pops up.
Current product versions are minecraft launcher version 2.1.1218 (stable), and Ubuntu version 18.04.1 LTS.
We have tried to remove the installation of minecraft launcher and re-install it, but it didn’t help.
snap version is 2.34.2+18.04

Have you tried running it in the terminal?

Either of these should output information on the console when you try to run them directly. This will help to understand what the problem might be.

snap run minecraft



Also it would be helpful for you to post the output of:

snap version


snap info minecraft

Thanks Daniel.

snap run minecraft

terminate called after throwing an instance of ‘std::runtime_error’
what(): locale::facet::_S_create_c_locale name not valid
Aborted (core dumped)

(same as calling /snap/bin/minecraft directly)

snap version

snap 2.34.2+18.04
snapd 2.34.2+18.04
series 16
ubuntu 18.04
kernel 4.15.0-29-generic

snap info minecraft

name: minecraft
summary: Minecraft is a game about placing blocks and going on adventures.
publisher: snapcrafters
license: unknown
description: |
A game about placing blocks and going on adventures.

It’s set in infinitely-generated worlds of wide open terrain - icy
mountains, swampy bayous, vast pastures and much more - filled with
secrets, wonders and peril!

  • minecraft
    snap-id: aJQRf6WPQq04DH0TB2HdTB6K9rf6I1yX
    tracking: stable
    refresh-date: 4 days ago, at 10:53 IDT
    stable: 2.1.1218 (14) 173MB -
    candidate: ↑
    beta: ↑
    edge: 2.1.1349 (15) 173MB -
    installed: 2.1.1218 (14) 173MB -

It looks like it’s failing to access something. Possibly the interfaces are all disconnected (this shouldn’t happen, but I have seen it on occasion).

Can you post the output of:

snap interfaces minecraft

If everything looks normal then we can also check the logs for messages including the word “audit” and “minecraft” in /var/log/syslog:

grep -i 'audit.*minecraft' /var/log/syslog

Two potential experiments are:

mv $HOME/snap/minecraft $HOME/snap/minecraft-backup

This will move the data directory of Minecraft away so that it rebuilds it again on launch (your saved games will be gone, which is why we renamed it rather than deleting. Renaming it back will restore previous saves, but might also restore brokenness.

The other option is to try a reboot, though I suspect you’ve already tried “turning it off and on again” :wink:


Interfaces seems to be connected:

snap interfaces minecraft

Slot Plug
:browser-support gnome-characters,minecraft
:desktop gnome-calculator,gnome-characters,gnome-logs,gnome-system-monitor,minecraft
:desktop-legacy gnome-calculator,gnome-characters,gnome-logs,gnome-system-monitor,minecraft
:home corsixth,gnome-characters,gnome-logs,minecraft
:joystick minecraft
:network corsixth,gnome-calculator,gnome-logs,minecraft
:network-bind corsixth,minecraft
:opengl corsixth,minecraft
:pulseaudio corsixth,minecraft
:wayland gnome-calculator,gnome-characters,gnome-logs,gnome-system-monitor,minecraft
:x11 minecraft

grep -i ‘audit.*minecraft’ /var/log/syslog

returned empty.

I also tried moving minecraft as you suggested. Didn’t do much difference…

I will try rebooting again (that’s the first thing I did, but who knows, maybe third time’s the charm…).