Migrating from core18 to core20: The specified command is not executable

Hey! I’ve tried to migrate my snap generation from Ubuntu18.04 to Ubuntu20.04 (using core20 instead of core18 as base snap) and now I’m getting the following error:

Failed to generate snap metadata: The specified command 'desktop-launch $SNAP/bin/geewallet-gtk' defined in the app 'geewallet' is not executable

This was allowed before when using the version of snapcraft available in Ubuntu 18.04. Any idea how to solve this? The snapcraft.yaml is here: https://github.com/nblockchain/geewallet/blob/frontend/snap/snapcraft.yaml

The CI failure is here: https://github.com/nblockchain/geewallet/runs/740879944

Try changing line 23 to:

command: bin/desktop-launch $SNAP/bin/geewallet-gtk

That fixed it thanks!

Hello again, somehow this got broken again but in a slightly different way.

Maybe because of an update in snapcraft that changed some behaviour?

When trying to launch the app from the command line (after installing the snap), I’m getting:

$ geewallet
/snap/geewallet/34/bin/desktop-launch: line 611: /snap/geewallet/34/bin/geewallet-gtk: No such file or directory

In fact, that file is not there anymore:

$ ls /snap/geewallet/34/bin/
desktop-launch  geewallet-console

My snapcraft file is here:

Arghh nevermind, I think this is a problem in our end; sorry for the noise.