Manual Review Requested: wpe-cli

Hi! We need to use “classic” on our app (for now) due to a heavy reliance on external apps and their configuration files. Specifically, we need to read and use configs for:

  • git
  • ssh
  • our own setup (which relies on a dot folder in home)

How can we get this pushed through?

Have you tried The personal-files interface as a means to read the configs you mention?

I’ve tried using it and, for predictable files, it seems to work. The issue comes in for websites cloned by users (this is a WordPress development tool). In this case, users should be able to clone their site anywhere they wish and each site can contain and arbitrary number of dotfiles and folders. personal-files doesn’t seem to work in that case as, from what I can see, all files have to be listed initially.

I would imagine this snap would plugs home, removable-media, ssh-keys and personal-files (for git), shipping any binaries it needs. Keep in mind that dotfiles are only an issue if they are toplevel in the user’s home; also, the snap’s $HOME is set to ~/snap/name/revision and the snap can use whatever dot files it wants there. Considering all of the above, can you comment specifically as to why this is not sufficient for your snap?

It appears this isn’t available yet in snapd for Ubuntu 18.04 ( How can we proceed with classic rather than an interface that is not yet supported?

Hi there!

The process and considerations have been outlined in this post near the bottom. It outlined a few additional things (beyond the process itself as well) and is a good read.

Have a good one.

personal-files is in 2.37 which is both the candidate snap and finding it’s way through the Ubuntu SRU process.

2.37 has been released to stable for a little while. What is the status of using this interface?

Marking this as resolved for now since personal-files should address the issue. Please get back in touch if this is not the case.