Kde-frameworks-5-96-qt-5-15-5-core20 error message, package not available

hello guys, I just had a problem and I don’t quite understand it well. I try to install freecad by this command

snap install freecad

it shows me this error message.

error: cannot perform the following tasks… “kde-frameworks-5-96-qt-5-15-5-core20”: no snap revision available as specified)

However, I look up at the snap store for the “kde-frameworks-5-96-qt-5-15-5-core20” package. I found it and I tried to install it by command line just as the capture says

But I get the following error message

error: el snap “kde-frameworks-5-96-qt-5-15-5-core20” no está disponible en stable pero está disponible para instalar en los canales siguientes:

   candidate  snap install --candidate kde-frameworks-5-96-qt-5-15-5-core20
   beta       snap install --beta kde-frameworks-5-96-qt-5-15-5-core20
   edge       snap install --edge kde-frameworks-5-96-qt-5-15-5-core20

   Tenga en cuenta que los canales de prelanzamiento pueden incluir
   caracteristicas que no han sido probadas o implementadas por completo.
   Obtenga más información con «snap info
   kde-frameworks-5-96-qt-5-15-5-core20».

Which basically it says me that the package I try to install is not available, I tried the same commands to try to install it on beta channel and edge but I get the same error message, so I want to ask, what am I missing ? or is there a problem with the kde package right now? If anyone has a solution for this please let me know, thanks.

Core20 is no longer supported for our content snaps as I have no way to do security updates. Freecad needs to update to core22. How have put back the content snap for now, but it will be removed again. I will try to find upstream and report this bug there.

1 Like

Bug reported upstream.

1 Like

thank you so much, I appreciate what you did.