Internal error, please report: running "dub" failed: canot find installed snap "dub" at revision 5

Just had a weird experience with the dub snap package that I maintain: trying to use it in a 32-bit 14.04 VirtualBox install that I use for testing, I got the above error.

Browsing the /snap/dub directory, I found that all the version directories (including current) appeared to be empty.

After an apt update; apt upgrade and a restart, things were available once again.

I don’t have any idea what could have happened, but the error message asked that I report it, so consider it reported :wink: