Inkscape snap uses a Windows 98 era window scheme

I got rid of PPA based Inkscape ( a lot of crashing was there ) and installed from Ubuntu Software in 18.04. Everything is good except for the fact that the window elements are dark grey ( something like we had in Windows 98 ). But when I choose Yaru theme, it works
( changes to a polished white close to #fff ). Is there any chance that the snap Inkscape make use of default theme like Firefox and other apps ?


Looks like a default GTK2 theme. What theme do you use in your desktop environment?

Nonetheless, I can see this happen under Gnome Shell on Arch too. When starting inkscape I see this in the terminal:

(inkscape:44452): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Is the snap missing the right engine to render the theme? cc @kenvandine

The engines are there in the gtk2-common-themes snap and it plugs the gtk-2-engines content slot.

From what I was able to confirm is that the snap should be using gtk-common-themes to get the themes instead of gtk2-common-themes which carries only the engines now. I did disconnected the themes content plug and connected it to gtk-common-themes:gtk-2-themes, but I’m still seeing the same problem.

Further investigation shows that the snap sets GTK_PATH to $SNAP/lib/gtk-2.0 where the engines are mounted, but once the process is running:

$ sudo strings /proc/162354/environ|grep GTK_PAT

It’s set differently. There is no pixmap engine in the Inkscape snap at that location, hence the warning. If that engine is required to render the theme, then GTK 2 will be unable to do so and will fall back to the default Win98 like theme.

I tried Plata and Adapta. Even tried the old Arc dark theme.

To be honest, I didn’t understand the rest.

I have been experimenting with different themes and the last one was Qogir. It worked everywhere else other than Inkscape snap. Looks Yaru is the only theme that works, not even Adapta

I found a discussion in this forum where there is a possible solution

I’m the one who posted that thread and received the solution and it does look like a similar issue.

For what it’s worth, I’ve put the fully-working Snapcraft.yaml for the Snap I was building up here. It might help you with this issue.

1 Like

For what is worth, the RC version of Inkscape uses GTK3 instead of GTK2 and integrates beautifully using snap (at least in Ubuntu 20.04). For me, it is very stable and performant, but as it is not stable yet, YMMV.

To switch: snap refresh inkscape --candidate


I will have to be on 18.04 for a couple of months at the least. So need to find some way not to get annoyed by the window bars. I think switching to Yaru is the only solution for me.

Thanks, I am not sure who is maintaining the Inkscape snap in 18.04. Hopefully that person might take a look or consider some changes.