Incorrect example installation command on

There appears to be a problem with snap package installation example. Once a package was built, the page showed me this:

To test this snap on your PC or cloud instance:
sudo snap install --edge iliv-test-0

Running this command resulted in:

error: cannot install “iliv-test-0”: snap not found"

However, when I clicked on the green text link “Built and published”, it took me to another page where the same command example was a little different:

sudo snap install --edge iliv-test-0 --revision=1

This one worked.

are you sure you waited long enough ?
it can take up to 20min til the snap is actually published in the store, when sees it as published, your dashboard will only have the “thumbs up” icon … but you will only find it in the store once that icon turned into the “green box” icon which can take quite a while (this is done by a cron job i think).

the first command should definitely work if the snap is fully published.

Well, I tried the second command (–revision=1) right after the first one. Like, immediately. Could be a coincidence. Unfortunately, I have cleaned up this test build so I can no longer verify.

In either case, the interface should not say “published” if that’s not true. I would be just as surprised if it said so and then snap install didn’t work.

Also, per recent conversations that sounds more like “released” than published, right?

1 Like

Yeah, it did state very clearly that the package was successfully built but it was not available for installation for some time. Which is confusing.

Hi @iliv, I’ve moved this to our bug tracker. Can you please subscribe to notifications there?


Hey @evan. I subscribed.