I am unable to record audio from several snaps

I can’t get sound recording working in:

  • Telegram
  • Audacity

It worked for a little bit in Slack, but no more.

Snappy-debug isn’t showing any errors. Slack and Telegram even list the interfaces. I have completely removed Audacity and the same.

I am running 20.04 (which has been upgraded from 19.10 to this point).

I am at a loss - and I have no idea where to look.

I is worth noting that Zoom works fine.

Try running snap connect $snap_name:audio-record in a terminal where $snap_name is the name of the snap, e.g. telegram-desktop or audacity. I believe that neither of those snaps have audio-record enabled by default so you need to grant the permission.

An alternative to running the command in a terminal is to use the Snap Store app (available as a snap itself), or Ubuntu Software on Ubuntu, to grant the permission by finding the page for the relevant snap and clicking the permissions button and toggling the item labelled “Record audio”:

I’ve already tried that, and given them all the permissions that I can :frowning:

OK, that’s certainly unexpected… And there are no relevant denials in the syslog, you said? Which suggests something more esoteric happening… Maybe someone better versed in the vagaries of the confinement can suggest a couple of debugging tips.

I know it sounds anathema but you might find a reboot helps… /me hides in shame for suggesting such a Windows idea ;-p

I’ve tried rebooting in the past Dan (we spoke about it on the Ubuntu Podcast Telegram channel).

It’s Gareth :smile:

I just made it work - I’ve installed Pulse Audio Volume Control. When I start recording I go to the recording and there I can change the input device. Pulse isn’t picking up what I have set as the default.

More playing required. Now to try Telegram.

1 Like

Aaah, that makes sense :slight_smile: silly me, sorry I didn’t make the connection of your problem to our discussion over there :wink:

I’ve had problems with pulseaudio selecting random input devices on reboot, or re-login, but invariably never the one I really want it to choose. I pretty much always need to reset it when I try to use my microphone :frowning: whoever said pulseaudio was panacea can eat my hat!