How to properly execute other binary trough sh from snap


I would like to ask for some help/guidance how to properly execute bin/sh from inside snap. I have tested many different approaches but not of them seams to work so far and I’m out of ideas.
I’m trying to build snap for binary that executes for example mosquitto_pub trough /bin/sh. I added dash to snap but binary still executes systems /bin/sh and command executed by binary - /bin/sh -c mosquitto_pub will not work because system is not aware of snap PATH.
So then I tried to rewrite /bin/sh with layout inside snapcraft.yaml but it is not possible - snapcraft is complaining about it upon snap build process.
Then I tried to run sh with full path, but also without much luck as binary and library path is unknown for sh:

~# /snap/some_app/current/bin/sh -c "ldd /snap/some_app/current/usr/bin/mosquitto_pub"
   => not found
   => /lib/x86_64-linux-gnu/ (0x00007fe82a734000)
            /lib64/ (0x00007fe82ab44000)

Only way I was able to run mosquitto_pub was providing path variables to full sh path:

~# LD_LIBRARY_PATH=/var/lib/snapd/lib/gl:/var/lib/snapd/lib/gl32:/var/lib/snapd/void:/snap/some_app/current/lib/x86_64-linux-gnu:/snap/some_app/current/usr/lib/x86_64-linux-gnu:/snap/some_app/current/lib:/snap/some_app/current/usr/lib:/snap/some_app/current/lib/x86_64-linux-gnu:/snap/some_app/current/usr/lib/x86_64-linux-gnu PATH=$PATH:/snap/some_app/current/usr/bin/:/snap/some_app/current/sbin/:/snap/some_app/current/bin/ /snap/some_app/current/bin/sh -c "mosquitto_pub"

Also end user is able to provide in config file what binary to execute like shell="mosquitto_pub ..." or shell="curl ..." and in standalone and docker versions it works, but in snap version asking end user to replace it with very long line would be inconvenient.

Hopefully I described my issue clearly, but if not - please do ask what I should clarify.

Any help would be much appreciated!

Sorry. I am not certain what you are asking / what the situation is. Is this an open source project where the repo is available? Or can you share the contents of the snapcraft file?

Sure, here is snap file.
I continued to experiment with layout and got it working with following config. It works for mosquitto_pub but to add curl same way I would need to add to 33 libraries, so I`m wondering - is it correct way of doing it?

    bind-file: $SNAP/usr/bin/mosquitto_pub
    symlink: $SNAP/usr/lib/$SNAPCRAFT_ARCH_TRIPLET/
    symlink: $SNAP/usr/lib/$SNAPCRAFT_ARCH_TRIPLET/