Hello world fails with segfault on arch linux

I’m going through the docs trying to get started, but running snapcraft always segfaults. e.g. I’ve got the following in snapcraft.yaml:

name: hello
base: core18
version: '2.10'
summary: GNU Hello, the "hello world" snap
description: |
  GNU hello prints a friendly greeting.
grade: stable
confinement: strict

    command: bin/hello

    source: http://ftp.gnu.org/gnu/hello/hello-2.10.tar.gz
    plugin: autotools

And I get this:

$ snapcraft
Support for 'multipass' needs to be set up. Would you like to do that it now? [y/N]: y
snapd is not logged in, snap install commands will use sudo
[sudo] password for root: 
multipass (latest/beta) 0.8.1 from Canonical✓ installed
Waiting for multipass...
Launching a VM.
Launched: snapcraft-hello                                                       
2019-09-28T00:00:35Z INFO Waiting for restart...
core 16-2.41 from Canonical✓ installed
snapcraft 3.8 from Canonical✓ installed
Segmentation fault (core dumped)

(core dump here: https://drive.google.com/file/d/1RFXoWKFAFbPrxg4IFcq0vR0equc0FCJG/view?usp=sharing)

I got the same result when I followed the offlineimap example at https://snapcraft.io/first-snap/python. Any advice? As a workaround I’m thinking about running ubuntu in virtualbox and see if it works from there.

Just managed to build the snap successfuly on Arch. Comparing your log to one I got, looks like the segfault happened before snapcraft managed to pull in build dependencies using apt.

Some problems with Python segfaulting were previously seen on Arch, and were caused by glibc nss backends. at that time I’ve posted a workaround in this topic: Segmentation fault running snapcraft on arch linux

That fixed it. Thanks!