Handling of alternative terminfo settings (kitty-term)

Last night I was trying to use the kitty terminal with the matterhorn snap, and bumped into some issues, mainly related to the alternative TERMINFO kitty uses by default.

I managed to get this kind of working, by placing the new terminfo file in my home directory and start matterhorn via TERMINFO=$HOME/.terminfo /snap/bin/matterhorn, but that feels suboptimal.

The other way I found works (just not sure about the implications yet) is using an alternative TERM value, like xterm-256colors

I assume this is caused due to the fact that core18 does not have support for this terminal, so I was hoping for a clean solution for this.

1 Like

The htop snap had basically the same issue, and fixed it by adding kitty-terminfo to stage-packages and setting the TERMINFO_DIRS to point to the terminfo subdirs under $SNAP (check this commit). Of course you can’t fix the snap as a user, but maybe you can manually set that envvar as an alternative.