Gnome-system-monitor settings saved only on exit


#1

Hi all,

I can’t change process list options on gnome-system-monitor snap. Using the “hamburger” icon, I change from “My processes” to “All processes” and it acts accordingly, for a small fraction of time, then shows only my processes again, even though “All processes” is still checked. If I close and open the snap again, then it shows “All processes” correctly, as selected. It seems tha changes are only saved when application is closed. Anyone else seeing this?

Using Ubuntu 18.04. Tried removing, deleting snap home folder, installing again, nothing. Tried also apt package - working perfectly.


#2

What are the versions of System Monitor that you’re running from the Ubuntu repos and from the snap?


#3

Latest for both:

$ snap info gnome-system-monitor
name:      gnome-system-monitor
summary:   System Monitor
publisher: Canonical✓
contact:   https://bugs.launchpad.net/ubuntu/+source/gnome-system-monitor/+bugs?field.tag=snap
license:   unset
description: |
  GNOME System Monitor is a GNOME process viewer and system monitor with
  an attractive, easy-to-use interface, It has features, such as a tree
  view for process dependencies, icons for processes, the ability to hide
  processes that you don't want to see, graphical time histories of
  CPU/memory/swap usage, the ability to kill/renice processes needing root
  access, as well as the standard features that you might expect from a
  process viewer.
commands:
  - gnome-system-monitor
snap-id:      9BTClmjz31r0UltmbJ5nnGe0Xm1AzfMp
tracking:     stable
refresh-date: today at 14:39 -03
channels:
  stable:    3.32.1-2-ga7c19eaeff 2019-06-04 (83) 3MB -
  candidate: 3.32.1-2-ga7c19eaeff 2019-06-03 (83) 3MB -
  beta:      ↑                                        
  edge:      3.32.0               2019-03-14 (67) 3MB -
installed:   3.32.1-2-ga7c19eaeff            (83) 3MB -
$ apt show gnome-system-monitor
Package: gnome-system-monitor
Version: 3.28.2-0ubuntu1
Priority: optional
Section: gnome
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 1.978 kB
Depends: dconf-gsettings-backend | gsettings-backend, libc6 (>= 2.14), libcairo2 (>= 1.2.4), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.55.0), libglibmm-2.4-1v5 (>= 2.54.0), libgtk-3-0 (>= 3.22.0), libgtkmm-3.0-1v5 (>= 3.22.0), libgtop-2.0-11 (>= 2.37.90), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), librsvg2-2 (>= 2.35.0), libsigc++-2.0-0v5 (>= 2.2.0), libstdc++6 (>= 5.2), libsystemd0
Recommends: gvfs
Homepage: https://wiki.gnome.org/Apps/SystemMonitor
Task: ubuntu-budgie-desktop
Supported: 5y
Download-Size: 193 kB
APT-Sources: http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages

#4

I can reproduce this on 19.04 with the same snap version as you (3.32.1-2 build 83), while the latest version from the Ubuntu repos (3.32.1-1) works fine.

There’s a bug report for this in Launchpad, but they say that this has been fixed and released in version 70 of the snap. I guess we should reopen that bug.

Does anyone know if the snapcraft.yaml for gnome-system-monitor is publicly available? I don’t see it in the Launchpad repo. I’m not sure without looking at the git history whether this is a regression or if the issue was never fixed in the first place.


#5

This was definitely fixed in revision 70. The specific fix was actually building it based on core18/bionic with a newer version of GTK. This is a new bug that I’ll look into.

It was fixed with this commit: https://bazaar.launchpad.net/~ubuntu-desktop/gnome-system-monitor/snap/revision/26


#6

Ok. Thanks for the context.