Gnome-calculator does not respect shell theme

I think this is a plug that could be added, but I can’t seem to find the repository. As you can see from the screenshot, the Gnome Shell theme isn’t respected.

What is your GTK theme used in the system? The gtk-common-themes content snap can only support those that are shipped within it.

I’m using the communitheme snap theme

According to Snaps officially supported by Canonical you may want to file a bug with the snap tag at Report a bug : Bugs : gnome-calculator package : Ubuntu

1 Like
1 Like

Is this on a Wayland session by any chance? If so, this is down to the method of GTK uses to pick a theme on Wayland seeing different default values in the confinement jail compared to the host system.

There has been some work to add an xdg-desktop-portal interface to expose those settings used by applications and corresponding changes to GTK to use that portal, but (a) we will need to upgrade xdg-desktop-portal on the host, and (b) the snap application would need to update to the new GTK.

As a workaround, you could try using dconf-editor to change your theme to explicitly set the theme rather than having it unset and relying on the default.


Thanks for the reply! Yes, you’re correct in that assumption (I should have mentioned it). I’ll have a look in dconf, do you know the tree to get to the theme key and also what value to use for “communitheme” / “yaru”?

Running the following from the command line might be the easiest:

gsettings set org.gnome.desktop.interface gtk-theme Yaru

On Wayland (and for some X11 applications), the window decorations are drawn client side rather than by the window manager. So their appearance is driven by the GTK theme rather than a separate shell theme.


Thanks, I think the correct setting is
gsettings set org.gnome.desktop.interface gtk-theme Communitheme