Falkon snap only built for amd64

Bug on web page: https://forum.snapcraft.io/

Following the instructions given on that page for performing installation of the Falkon web browser using snap yields the following:
# snap install falkon
error: snap “falkon” is not available on stable for this architecture (i386) but exists on other architectures (amd64)._

Perhaps it’s not a functionality bug, in the event i386 packages are no longer available. But if that is the case, it is instead a documentation bug in that, assuming that prior termination of i386 package availability was the cause, the page has failed to inform it’s audience that installing snap as the first step described for the process of installing falkon would be a fultile exercise for those using the i386 architecture. It should be noted that pages leading a user to their ultimate arrival here give him/her no indication that he/she might be trotting toward a dead end.

Contact the falkon snap developers and ask them to also build it for i386? (while you’re at it, also ask them to build it for all the other architectures they’re missing).

Edit to add: can you point to exactly where it’s said to install falkon, so that we can make a note on the topic unitl the developers do this?

Thanks for the rapid reply.
Looking at the link you provided, it seems that if I continue to want to try out falkon on my old, old hardware, my third step in trying to download it will need to be to create a a KDE bug management account and potentially be the first person to submit a bug report about it’s unavailability here, over there ( I guess submitting a bug report regarding a failure of installation step 2 was premature and required further research before the right report could be submitted to the right place).

if that’s very onerous for you, maybe wait a bit and see if any of the devs hang around this forum (I wouldn’t presume they do, but, maybe!)

edit to whisper @sitter to the wind

I wouldn’t call it onerous, this has just involved a lot more steps for installation of a browser than I had anticipated.

I’m in the middle of submitting the report at the site you gave me a link to, including all of the details of each step I have found to be necessary for installion of Falkon, including:

  1. Finding installation instructions which indicated that installing snap on Mint would be the simples of 3 approaches, the other two involving things bearing the names FlatPack and Appimage. From meager descriptions, I suspected that rather than using shared libraries those other approaches might have involved partially or fully statically linked binaries, which would have been disastrous on this old limited-core machine, which becomes crippled during swapping activity.

  2. Installing snap.

  3. Following the instructions for using snap to install Falkon

  4. Getting an error message carrying an implication that following the supplied instructions had been insufficient.

  5. Finding a link pointing to applying for a bug account here.

  6. Starting up thunderbird to be able to click a link so as to complete creation of this account.

  7. Submitting the bug report here, getting a rapid reply.

  8. Creating a bugtrack account at KDE

  9. Going back to Thunderbird to be able to click a link there so as to complete creation of that account

  10. Initiating the bug report at the KDE bugtracker.

  11. Hopefully, there won’t be too many more steps remaining to complete the installation of this browser.

Maybe this level of detail can help the maintainers with insight toward future consideration of the amount of time potentially spent by multiple end-users in what ultimately ends up having been futile exercises (which really should not have had to be repeated by each and every one of them before giving up, which is what most people actually do, and what I suspect a lot of others have already done).

1 Like

I place the following under ADDITIONAL INFORMATION of the bug report:
Contact the falkon snap developers and ask them to also build it for i386? (while you’re at it, also ask them to build it for all the other architectures they’re missing).

The Mint install instructions are on https://snapcraft.io/install/falkon/mint

The Ubuntu install instructions are at: https://snapcraft.io/install/falkon/ubuntu

Mint is just a repackaging of Ubuntu, but uses the same underlying packages. For these purposes, the only difference is that a standard Ubuntu system comes with snap already installed, which mint doesn’t.

Other repackagings of Ubuntu (Kubuntu, Lubuntu, Edubuntu, Xubuntu, etc) may or may not have snap preinstalled. I don’t know.

ah, ok. That’s not https://forum.snapcraft.io/ (which you said it was), so that’s probably ok then: the main page for the snap itself, https://snapcraft.io/falkon, does say the snap is only there for amd64.

(it’s still bug-worthy that they’re only building for amd64, but it’s not something we can fix from here)

I think maybe there’s a miscommunication here. snap is doing exactly what it should. i386 packages have not been removed (contrary to recent news).

The snap store can host snaps for numerous architectures. It’s up to the developer what architectures they choose to build for and support. There are many snaps which are amd64 only, many armhf only, and even more which are multi-architecture.

The fact that there is no i386 snap of falkon is not technically a bug, but if it is, it’s a “wishlist” one, that the upstream developer can choose to address, or not. It’s not a bug in snapd, the forum or the website. However we could possibly improve the visibility of of which architectures are available from the distro specific pages.


I think I must have pasted the contents of the clipboard with my having experienced an unobserved failure to to copy the URL of the install page page into it, so the prior contents got pasted instead of what I expected to be pasted.

However, I think we may both be experiencing “Twilight Zone” moments: I just now tried a search for “64” within https://snapcraft.io/falkon, and as soon as I typed the “4”, the search box turned red. The string amd64 does not exist there. It’s html source does however contain one instance of a javascript reference to the string “amd64” in an argument to a call to snapcraft.public.channelMap().

at the top right, next to the install button of each snap on snapcraft.io you find a pulldown. if you open it it shows all available releases in all channels and architectures.

To be clear. This panel.

Makes sense. That rectangle corresponds to the javascript code I’d mentioned in my previous post.

The presence of the “Amd64” string in that source had seemed an anomaly to me at the time, however, as in Qupzilla ( the only browser on this system that both doesn’t have a high risk of crashing while at the same time not making the load average jump to a range between 5 and 10 when you run it). Searching for the string “64” on that page yielded a red search box and when I moved the cursor over that rectangle, it’s color changed from white to grey, while clicking on it produced no response.

I subsequently tried Firefox after reading your message, and lo and behold, after a lengthy wait, found that it’s it’s not just a brick that changes color!

(you can see why I’m interested in Qupzilla’s younger sibling: Falkon is reportedly fully functional while retaining Qupzilla’s (vastly superior to firefox or chrome) performance, which is of a level upon which I’m dependent until I can get a replacement for a gaming laptop I had recently “bricked” when I accidentally shorted it’s power supply by absentmindedly inserting a different usb connector than intended (a slimmer one, which unfortunately had a metal sleeve) `into one of it’s usb slots.)