Exception in push command

Today I was pushing a snap and got this exception. Is it useful to post it here?

alejo @ ~/git/automaton-builder - [prod] $ snapcraft push automaton-builder_2.51_amd64.snap --release stable
Preparing to push 'automaton-builder_2.51_amd64.snap'.
After pushing, the resulting snap revision will be released to 'stable' when it passes the Snap Store review.
Running the review tools before pushing this snap to the Snap Store.
Generating delta for 'automaton-builder_2.51_amd64.snap'.
Pushing 'automaton-builder_2.51_amd64.snap.xdelta3' [===================================================================================================================================================================================] 100%
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/snap/snapcraft/4282/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "/snap/snapcraft/4282/usr/lib/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/snapcraft/storeapi/_status_tracker.py", line 73, in _update_status
    for content in self._get_status():
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/snapcraft/storeapi/_status_tracker.py", line 83, in _get_status
    content = requests.get(self.__status_details_url).json()
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/requests/models.py", line 897, in json
    return complexjson.loads(self.text, **kwargs)
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/simplejson/__init__.py", line 516, in loads
    return _default_decoder.decode(s)
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/simplejson/decoder.py", line 370, in decode
    obj, end = self.raw_decode(s)
  File "/snap/snapcraft/4282/lib/python3.6/site-packages/simplejson/decoder.py", line 400, in raw_decode
    return self.scan_once(s, idx=_w(s, idx).end())
simplejson.scanner.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Does it work if you try again? Perhaps it was a transient network blip?

It never ended. I checked again and is still trying. I will try again now

I canceled it and got this

Processing...-
Processing...|
Processing...-
Processing...|
Processing...-
^Cocessing...-
Aborted!

I tryied again but it said that I cant upload the same content again. Doing info it says the new versions is available (instead of canceled)

alejo @ ~/git/automaton-builder - [prod] $ snap info automaton-builder
name:      automaton-builder
summary:   Tool for building and testing automatons
publisher: Khipu Developer (khipuspa)
store-url: https://snapcraft.io/automaton-builder
license:   unset
description: |
  Automaton Builder is a tool for building and testing automatons for Khipu
  infrastructure.
commands:
  - automaton-builder
snap-id:      Cv1ojO0eGzPqVJu3wY3s14JDjLLD4Upn
tracking:     latest/stable
refresh-date: today at 16:13 -04
channels:
  latest/stable:    2.51 2020-05-08 (13) 193MB -
  latest/candidate: ↑
  latest/beta:      ↑
  latest/edge:      ↑
installed:          2.51            (13) 193MB private

Also, is instaled in that Machine. I have not tried to run it so I do not know if the upload is ok.

Something else?

If snap info shows it released, it’s all fine. Most likely there was a network blip between you and the store while snapcraft was waiting for it all to finish, but it completed successfully in the background.

1 Like