Errors installing anbox (Ubuntu 18.04)


#1

I am new to Linux and not sure how to fix these problems.
I have attached an image showing the two problems while running the following commands
$ sudo apt install linux-headers-generic anbox-modules-dkms
$ snap install --devmode --beta anbox
I am running the update command as well. It returned there are 317 packages that could be updated. I installed the updates.

https://i.stack.imgur.com/Pbmwo.png (IMAGE OF TERMINAL ERRORS)


#2

The first line has errors. You need to at the minimum re-run that first command as it failed. This failed likely because in the background something else was updating your system. So try re-running that first command first. Also, can you paste the output of running the command snap version here, to help us debug?

Also, are you following these instructions https://github.com/anbox/anbox/blob/master/docs/install.md ?


#3

I ran the line again. I am still getting the same errors. I am following the instructions at the link you listed! I just reinstalled Ubuntu and tried again. Same errors as before Below are my results from running the snap version command.

snap 2.36.3
snapd 2.36.3
series 16
ubuntu 18.04
kernel 4.15.0-43-generic