Error: os_dlopen(libobs-opengl.so.0->libobs-opengl.so.0): /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33' not found (required by /var/lib/snapd/lib/gl/libEGL.so.1) OBS-Studio (Arch / Manjaro)

Hello,

I would like to report a potential bug like created at the Github repo of snapcrafters /
obs-studio
.
A member of the snapcraft community assumed in the issue that the “host opengles library is unable to be loaded due to the OBS snap and its base snap including an older libc library”.
I don’t understand much about it but still wanted to do something and here I am. :grinning_face_with_smiling_eyes:

Console output:

[dennis@LinuxGamingMachine ~]$ obs-studio
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: Command Line Arguments: --multi
info: CPU Name: AMD Ryzen 7 2700X Eight-Core Processor
info: CPU Speed: 4149.727MHz
info: Physical Cores: 8, Logical Cores: 16
info: Physical Memory: 32029MB Total, 17379MB Free
info: Kernel Version: Linux 5.13.4-1-MANJARO
info: Distribution: "Ubuntu Core" "20"
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.20.11
info: Portable mode: false
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /usr/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_tbar_position_valueChanged(int)
QMetaObject::connectSlotsByName: No matching signal for on_actionShowTransitionProperties_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_actionHideTransitionProperties_triggered()
info: OBS 27.0.0-modified (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
        samples per sec: 48000
        speakers:        2
error: os_dlopen(libobs-opengl.so.0->libobs-opengl.so.0): /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33' not found (required by /var/lib/snapd/lib/gl/libEGL.so.1)

error: Failed to initialize video:  Graphics module not found

Please let me know if you need more details.