Desktop icon missing on "AppStream enabled" Snap

Hi all, need some help.

I’m creating a new Snap, as per-request here - Giara. Developer provides an AppStream entry on source, so I decided to give it a go. Everything went fine, overall, except the error below, shown on priming step of Snapcraft:

Icon usr/share/icons/hicolor/96x96/apps/org.gabmus.giara.xpm specified in desktop file /root/prime/usr/local/share/applications/org.gabmus.giara.desktop not found in prime directory

Installing the created Snap gives me a desktop entry, as expected; also, as expected, there’s no application icon, just generic one.

I’ve tried some workarounds, unsuccessfully. Don’t want to manually create a desktop file, since AppStream + adopt-info seems to be working almost fine.

I’d appreciate any help. There’s the snapcraft.yaml.

Thanks in advance.

PR’d some workaround/fixes (https://github.com/ivocavalcante/giara-snap/pull/1), but there are two issues at play:

(1) snapcraft doesn’t search /usr/local. Updated parts to use /usr prefix. We probably should search /usr/local too as it’s the default prefix, or check relative to location of desktop file.
(2) snapcraft has a bug where it may not search scalable icons in some scenarios when using appid. We need to fix that.

Good luck!

1 Like

FWIW, I filed tickets for the two issues:


1 Like

Many thanks, Chris! Think this closes the case for now, while the issues you opened are worked on.