"cups" interface merged into snapd - Additional steps to complete

Sneak Preview

Update: No need to set the CUPS-SERVER environment variable in snapcraft.yaml of application Snaps.

For all the snappers around here, I want to give you a sneak preview, so that you can try out the new interface and also test your application Snaps. This way you do not need to wait for the release of snapd 2.55.

  1. Install the snapd Snap with cups interface: A snapshot of snapd with cups interface is available in the Snap Store, in the Edge channel. So you need to switch your snapd to the edge channel: sudo snap refresh snapd --edge --amend
  2. Get CUPS Snap source from OpenPrinting GitHub: The CUPS Snap currently in the Snap Store does not support the new cups interface. The change mentioned in the previous post needs to get applied. Therefore download the source of the Snap so that you can modify and rebuild it: git clone https://github.com/OpenPrinting/cups-snap.git
  3. Edit snapcraft.yaml: Look for the definition of the slots (slots:) and add the line “cups-socket-directory: $SNAP_COMMON/run” to the cups: entry (patch below). DO NOT add “assumes: [snapd2.55]” as the snapshot of snapd still has a 2.54. … version.
  4. Rebuild the CUPS Snap: To rebuild your modified Snap you need to have snapcraft installed. Then you run the command snapcraft snap
  5. Make sure the CUPS Snap from the Snap Store is installed: If it is not done yet, install the CUPS Snap from the Snap Store, to make all its interfaces auto-connected: sudo snap install --edge cups
  6. Install your modified CUPS Snap on your system: You “upgrade” from the Snap Store’s version. The interfaces stay connected. Use the command sudo snap install --dangerous cups_0.1.0_amd64.snap

This is the patch for snapcraft.yaml of the CUPS Snap:

--- a/snapcraft.yaml
+++ b/snapcraft.yaml
@@ -66,6 +66,7 @@ slots:
     interface: cups-control
     interface: cups
+    cups-socket-directory: $SNAP_COMMON/run

Now we have the new CUPS Snap environment up and running, so we can do the first simple test:

Copy the following snapcraft.yaml:

name: cups-admin-test-no-control
base: core20 # The base snap is the execution environment for this snap
version: 0.1.0
summary: CUPS admin and non-admin tasks out of a Snap 
description: Testing interfaces for the CUPS Snap (no cups-control plugging, so admin tasks should fail)
grade: stable
confinement: strict

    command: usr/sbin/lpinfo
    plugs: [network, cups]
    command: usr/sbin/lpadmin
    plugs: [network, avahi-observe, home, cups]
    command: usr/bin/lpstat
    plugs: [network, avahi-observe, cups]
    command: usr/bin/lpoptions
    plugs: [network, home, cups]
    command: usr/bin/lp
    plugs: [network, home, cups]
    command: usr/bin/cancel
    plugs: [network, cups]
    command: usr/sbin/lpmove
    plugs: [network, cups]
    command: usr/sbin/cupsenable
    plugs: [network, cups]
    command: usr/sbin/cupsdisable
    plugs: [network, cups]
    command: usr/sbin/cupsaccept
    plugs: [network, cups]
    command: usr/sbin/cupsreject
    plugs: [network, cups]
    command: usr/sbin/cupsaccept
    plugs: [network, cups]
    command: usr/sbin/cupsreject
    plugs: [network, cups]
    command: usr/sbin/cupsctl
    plugs: [network, cups]

    plugin: dump
    source: .
        - cups-client
        - libcups2
        - usr/bin/*
        - usr/sbin/*
        - usr/lib/*

Put it into a new, empty directory, build, install it, and connect the interfaces:

snapcraft snap
sudo snap install --dangerous cups-admin-test-no-control_0.1.0_amd64.snap
sudo snap connect cups-admin-test-no-control:avahi-observe
sudo snap connect cups-admin-test-no-control:cups cups:cups

The Snap simply puts together the command line tools of CUPS, exactly the ones of the CUPS package which comes with Ubuntu 20.04 LTS, what core20 is based on. Some commands are administrative, like lpadmin or lpinfo and others are not, like lp or lpstat.

In the snapcraft.yaml you see how easy it is to use the interface. If one of the contained applications (apps: section) wants to print or otherwise non-administratively access CUPS (for example to list print queues and/or jobs) you only need to add cups to the application’s list of plugs:. If you have an own Snap with an application which prints but not a printer setup tool, simply replace cups-control in the plugs: by cups.

Now let us execute some of the commands in this Snap:

$ cups-admin-test-no-control.lpstat -H
$ cups-admin-test-no-control.lpstat -v
device for printer_on_snap: ...
$ cups-admin-test-no-control.lpinfo -v
lpinfo: Forbidden
$ cups-admin-test-no-control.lpadmin -x printer_on_snap
lpadmin: Forbidden
$ cups-admin-test-no-control.lpstat -v
device for printer_on_snap: ...

You see that you get a Forbidden on administrative commands and the others work normally. Also the Snap’s commands are talking to the snapped CUPS (cups-admin-test-no-control.lpstat -H gives /var/cups/cups.sock and not /run/cups/cups.sock). You only see your system’s CUPS queues because the CUPS Snap is running in proxy mode.

If you use the cups-control interface instead of cups for the plugs:, your Snap will talk directly to your system’s CUPS and the administrative commands will work.

Now you could try out one of your application Snaps, like a GUI application where one can print via a print dialog. If you do the changes correctly and manually connect your Snap’s cups interface with cups:cups, the print dialog should work normally, listing the available print queues and allowing you to set options and print the job.

Do not try this with a printer setup tool like system-config-printer, as a result it will show you the current print queues but you will not be able to modify them or add new one. Such applications have to continue using cups-control.

Also do never use the cups interface for one application in your Snap and the cups-control interface in another. As you will request manual permission for your Snap to auto-connect cups-control anyway, use cups-control for all the applications. Or create two Snaps, one containing only the non-administrative applications and another one only the administrative ones.

Please post your experiences and questions here in this thread.

About the needed environment: in the application Snap’s snapcraft.yaml I have added an item to the TODO list.

About the fact that one should not use cups and cups-control in the same Snap I have already posted in the PR on Nov 2, 2021 and today @jdstrand has commented on this that this could be a checked in the review-tools and asked @alexmurray about this idea and he agreed with it.

Thanks, @jdstrand and @alexmurray.

this is not necessary, snapd will now automatically set CUPS_SERVER for the snap that has plugs: [cups] in it, please do not add CUPS_SERVER definition inside snaps. This is so that some day we may change this to use /run/cups/cups.sock instead, we want to be able to do this transparently from inside snapd without changing application snaps

1 Like

@ijohnson Thanks, I have updated the TODO list and also the testing instructions now.

Some updates:

  • The Snap Store team has no granted auto-connect of the cups slot of the CUPS Snap.
  • No special permission is needed for using the cups-socket-directory attribute.
  • For the CUPS Snap auto-installation to work, there must be a version of the CUPS Snap in the stable channel of the Snap Store. This I have done now.
  • For the CUPS Snap we will later on look into adding appropriate functionality to snapd that it is simply done if a Snap is installed which plugs cups. For the time being there is a workaround which does not require any change in the snapcraft.yaml of the CUPS Snap, it is enough to add the default-provider: cups to the snapcraft.yaml files of the client Snaps which plug cups using a placeholder content interface as shown below.
  • Later on default-provider support should be added directly to the cups interface. @mvo, could you work on this with me?

Here is what has to be added to client application Snaps which plug cups in order to auto-install the CUPS Snap (if it is not already installed):

    interface: content
    content: foo
    target: $SNAP_DATA/foo
    default-provider: cups

What is mainly still missing is:

  • snapd 2.55 release
  • /var/snap directory to be created in the base Snaps
  • Add cups-socket-directory: $SNAP_COMMON/run and assumes: [snapd2.55] to snapcraft.yaml of CUPS Snap (required snapd 2.55 release)

TODO list above updated.

@ijohnson @mvo how will we proceed?

Thanks for the update of the status and the outstanding tasks.

Given the workaround above I would like to put this particular task into the roadmap for the next cycle.

We (@ijohnson, @mvo, and me) had a meeting Ysterday on the Canonical Sprint in Frankfurt and coordinated the tasks:

  1. @ijohnson will add the /var/snap directories to the base Snap. This will happen rather quickly, some days.
  2. @ijohnson and @mvo will release snapd 2.55.0. This will take 2-4 weeks from now, as there will be put out another bug fix release (2.54.4) before.
  3. As soon as snapd 2.55 has landed I will add cups-socket-directory: $SNAP_COMMON/run and assumes: [snapd2.55] to snapcraft.yaml of CUPS Snap and commit this.
  4. Announcement of the cups interface and its usage here on the forums (snapcraft and snapd).

Notr that what I wrote above is the first approach of the cups interface working as designed, but there is still an ugliness. The packager of a client application cannot simply only plug cups but he also needs to add the content interface plug definition with default-provider: cups to snapcraft.yaml Therefore we have also

  1. Add default-provider: cups supoort directly to the cups interface in snapd. This @mvo has added to the roadmap of the upcoming development cycle. It will be done in April or May.
  2. Post an update announcement telling that plugging cups is all which have to be done so that a client application can print.

So user application snappers will be able to use the cups interface in 2-4 from now, but in some months it will get really easy to use it.

For testing the cups interface @ijohnson has created a small test Snap (Snap Store) and it shows that auto-download of the CUPS Snap and auto-connection of the cups interface to the CUPS Snap’s slot actually work. Actual printing and communication with CUPS could not be tested as the Snap has a little bug.

@ijohnson has posted PRs to the core Snaps to add /var/cups: core, core-base, core18, core20.

The PRs got all merged now, thanks @ijohnson and @mvo.

As the review-tools of the Snap Store already require the “cups-socket-directory: $SNAP_COMMON/run” line in snapcraft.yaml I have committed its addition in the CUPS Snap now. Technically the CUPS Snap is completed now for the new cups interface, but to assure that the cups interface will work for everyone, we will add the assumes: [snapd2.55] as soon as snapd 2.55 makes it into the stable channel of the Snap Store.

Recent tests have revealed the following bug:

In a client application I observed that the CUPS_SERVER environment variable did not get set and therefore the snapped application tries to access CUPS on the standard socket of the system’s CUPS, and not on the mounted socket of the CUPS Snap.

After @ijohnson told me that he cannot reproduce the bug I have reported on Launchpad (previous comment) I tried testing again, snapd having auto-updated to version 2.54.4+git1079.gbf8d25c (from the Edge channel of the Snap Store), and this time everything worked again. We have closed the bug report now.

As the editability of the original TODO list has expired (after 1 month) I am re-posting it here to document the further development:


What still needs to be done is the following:

  • snapd 2.55 release: The new snapd with the included cups interface needs to get released to the stable channel of the Snap Store. This will happen in 2-3 weeks from now.
  • Snap Store permissions: [DONE] Request permissions from the Snap Store team for the CUPS Snap to use the cups-socket-directory attribute and for auto-connection of any Snap’s cups plug to the cups slot of the CUPS Snap. I have already posted the request here on the forum.
  • /var/snap in base Snaps: [DONE] @ijohnson will post PRs (Update: has posted, see below, and they got all merged) on the base Snaps to create the /var/snap directory. @ijohnson: There are some other PR’s I will file to the base snaps which will behind the scenes make using the cups interface more efficient, but that will not change how it’s used at all (it will just change the mount namespace setup by creating the /var/cups directory there so we don’t have to do lots of mount tricks)
  • CUPS Snap auto-installation: [DONE via placeholder content interface] When an application Snap plugging cups gets installed from the Snap Store and the CUPS Snap is not installed (or a too old version), the CUPS Snap gets automatically installed in addition to the application Snap, like a package dependency. @ijohnson plans to adapt the default-provider setting to also work for the cups interface here: We have to either manually enable this using a transitional placeholder content interface or adapt the default-provider setting to also work for the cups interface. I plan on doing the latter at some point soon so I don’t think that the former needs to be implemented.
  • Snapcraft extension to auto-set CUPS_SERVER environment variable: [NOT NEEDED ANY MORE] Currently in the snapcraft.yaml of an application Snap using the cups interface we have to set the CUPS_SERVER environment variable to /var/cups/cups.sock via environment: entry. This can be made automatic by a snapcraft extension. @ijohnson: That environment variable setting could probably be done with a snapcraft extension, which is not added to snapd, but rather to snapcraft itself. The extension could look like this and also cover the CUPS Snap auto-install. Update: The automatic setting of the CUPS_SERVER environment variable is already done by snapd.
  • Changes in CUPS Snap: [IN PROGRESS] The CUPS Snap needs to have the correct cups slot definition, as shown in my earlier post, with the “cups-socket-directory: $SNAP_COMMON/run” line added (Update: This line is added now, was needed by Snap Store’s review-tools to accept the CUPS Snap) and also in the beginning of the snapcraft.yaml a line “assumes: [snapd2.55]” added (Update: This line is commented out now, as snapd 2.55.2 got withdrawn from the stable channel) as then the Snap will perhaps not work with older snapd versions any more. The latter I only will do when snapd 2.55 gets actually released to the stable channel, to make sure that the CUPS Snap can always be downloaded and used.

With all this done we will be able to launch the new cups interface and tell all the snappers out there to use it for their printing applications, like LibreOffice, Darktable, evince, gedit, … And we are really close, only the release of snapd 2.55 is missing and probably the next landing of the core Snaps.

Update: snapd 2.55.2 is NOT yet in the stable channel, seems that it got put and withdrawn right after.

1 Like

Some news about our progress:

  • Core Snaps with /var/cups directories, at least core18 and core20, are in the stable channel now.
  • snapd 2.55.2 will reach the stable channel on Tue, April 5, 2022
  • We have found a bug in snapd, snapd setting the CUPS_SERVER environment variable to /var/cups/cups.sock not only when the cups interface is plugged but always, on any Snap, and so breaks the CUPS Snap and Snaps which plug cups-control and not cups. A PR on snapd, at least to address the case of the CUPS Snap, got posted by @mvo. Thanks a lot for working with me on the fix and posting the PR. He is also working on a solution for the cups-control case. In the proxy-mode the CUPS Snap works correctly even with this bug present.

Also thanks to @cachio for his testing work and finding several bugs concerning the cups interface in snapd and the CUPS Snap.

Update: snapd 2.55.2 is NOT in the stable channel. Seems that it got accidentally promoted and withdrawn right after. Therefore I have commented out the assumes: [snapd2.55] line in the snapcraft.yaml of the CUPS Snap now.

snapd 2.55.2 made it into the Stable channel and I have added the assumes: [snapd2.55] line to the snapcraft.yaml of the CUPS Snap, so the TODO List above is completed.

The Pull Request to fix the bug of CUPS_SERVER always being set to /var/cups/cups.sock regardless of cups plugged or not which I mentioned two posts earlier here got merged and you get the fix included if you upgrade your snapd to the one on the Edge channel:

sudo snap refresh --edge snapd

(Must be 2.55.2+git188.ge21669c or later, check with snap version or snap list)

This fixes the bug for both the CUPS Snap and Snaps plugging cups-control. My earlier assumptions that the latter are not covered was wrong.

I have tested the fix intensively (see my comments in the PR starting here) and with the workaround described below everything is working as designed!

So principally we are ready to go with the cups interface, but there is still a little problem when updating to the fixed snapd. If a Snap, especially the CUPS Snap has the environment variable set and after that we update snapd and restart the CUPS Snap, the variable stays set. There is some kind of cache pertinent through restart of the Snap.

To clean up this, once having updated snapd to the Edge version, run

sudo /usr/lib/snapd/snap-discard-ns cups

and the variable gets immediately cleared so that you can use the CUPS Snap and its cups interface correctly from now on.

Also all your Snaps which plug cups-control need this clean-up as otherwise you cannot print from these Snaps. Note that there are several, as cups-control was the interface used up to now also if one just wants to print. Run the following command for each Snap:

sudo /usr/lib/snapd/snap-discard-ns SNAPNAME

replacing SNAPNAME by the name of the Snap to fix. Run

snap connections | grep cups-control

to find all your installed Snaps which plug cups-control.

You need to run snap-discard-ns on your Snaps only once and never again, only when you update from a still buggy snapd from version 2.55 on and older than 2.55.2+git188.ge21669c to a fixed version, 2.55.2+git188.ge21669c or newer.

So we hae now the following new TODO list:

To be done as soon as possible:

  • Create an automated way to get rid of the CUPS_SERVER environment variable wrongly set by a buggy snapd, for example let snapd (snap-exec) unset the CUPS_SERVER environment variable if it finds that the /var/cups/ directory is not bind-mounted meaning that cups is not plugged, so when not setting CUPS_SERVER=/var/cups/cups.sock unsetting CUPS_SERVER. Or do a snap-discard-ns on all installed Snaps every time snapd is updated.
  • Sort out the snapd 2.55.x release into the stable channel.

To be done during the coming weeks/months:

  • Let snapd directly auto-install the CUPS Snap when we are installing a Snap which plugs cups, without the currently used placeholder content interface. This way a snapper only needs to add cups to the plugs of an app so that it can print, nothing more. No ugly content interface entry needs to be added then.
  • Let snapd be able to set environment variables triggered by plugging a given interface (and remove them if the interface is not plugged any more). This way we can get rid of the current workaround of checking for the bind mount on /var/cups/ and we can set environment variables also for other interfaces, where the use of them cannot get detected that easily.

@mvo thanks a lot for your cooperation with me to debug the CUPS_SERVER environment variable issue, for posting the PR, and for adding the long-term TODOs to the current developemnt cycle, and thanks @cachio, @mardy, and @pstolowski for approving the PR so quickly.

1 Like

snapd 2.55.2 is NOT in the stable channel. Seems that it got accidentally promoted and withdrawn right after.

Perhaps it was withheld due to the bug I described in the previous post, perhaps due to other bugs. I do not know …