Cloud build proxy auth errors, build now failing

As of today, the cloud build is getting a proxy auth error and failing for a snap that has always built fine in the past.

Get:1 libwacom2_1.3-2ubuntu3_amd64.deb [20.0 kB]                                

Fetched 20.0 kB in 0s (0 B/s)                                                   

Err libsensors-config_3.6.0-2ubuntu1.1_all.deb                                  

  407  Proxy Authentication Required [IP: 10.10.10.1 8222]                      

Fetched 0 B in 0s (0 B/s)                                                       
Build failed
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 265, in run
    self.pull()
  File "/usr/lib/python3/dist-packages/lpbuildd/target/build_snap.py", line 205, in pull
    self.run_build_command(
  File "/usr/lib/python3/dist-packages/lpbuildd/target/operation.py", line 62, in run_build_command
    return self.backend.run(args, cwd=cwd, env=full_env, **kwargs)
  File "/usr/lib/python3/dist-packages/lpbuildd/target/lxd.py", line 716, in run
    subprocess.check_call(cmd, **kwargs)
  File "/usr/lib/python3.8/subprocess.py", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['lxc', 'exec', 'lp-focal-amd64', '--env', 'LANG=C.UTF-8', '--env', 'SHELL=/bin/sh', '--env', 'http_proxy=http://10.10.10.1:8222/', '--env', 'https_proxy=http://10.10.10.1:8222/', '--env', 'GIT_PROXY_COMMAND=/usr/local/bin/lpbuildd-git-proxy', '--env', 'SNAPPY_STORE_NO_CDN=1', '--env', 'SNAPCRAFT_LOCAL_SOURCES=1', '--env', 'SNAPCRAFT_SETUP_CORE=1', '--env', 'SNAPCRAFT_BUILD_INFO=1', '--env', 'SNAPCRAFT_IMAGE_INFO={"build-request-id": "lp-82814869", "build-request-timestamp": "2023-10-03T19:41:11Z", "build_url": "https://launchpad.net/~build.snapcraft.io/+snap/020409518a612effd6e2df7166937cce/+build/2248825"}', '--env', 'SNAPCRAFT_BUILD_ENVIRONMENT=host', '--', '/bin/sh', '-c', 'cd /build/cluemaster-videoplayer-core && linux64 snapcraft pull']' returned non-zero exit status 2.
Revoking proxy token...

Looks like the proxy errors have stopped. Snap Store issue is resolved. Not sure what was happening.