Classic confinement request for wdune


#1

As far as i understood snapcraft,

snap install --classic --dangerous ./wdune_1.393_amd64.snap

snapcraft login

snapcraft push --release edge wdune_1.393_amd64.snap
…he store was unable to accept this snap.

  • confinement ‘classic’ not allowed with plugs/slots
  • (NEEDS REVIEW) confinement ‘classic’ not allowed. If your snap needs classic confinement to function, please make a request for this snap to use classic by creating a new topic in the forum using the ‘store-requests’ category and detail the technical reasons why classic is required.

The program need to access the internet for downloading VRML/X3D files via libcurl


#2

Classic is not needed for this. Check out the network interface: https://snapcraft.io/docs/network-interface

  • Daniel