Can't ssh to Ubuntu Core on Raspberry Pi 3 with public IP

When I try to ssh to my Ubuntu Core Raspberry Pi 3 using its private IP (i.e. 10.x.x.x) it is able to connect, but when I try remotely from its public IP or hostname, it says

ssh: connect to host <public ip/hostname> port 22: Network is unreachable

Is this a default security feature of Ubuntu Core to only accept local connections or is something not configured correctly with the OS/firewall/router?

It isn’t a feature of Ubuntu Core, as far as I’ve seen.

  1. Have you set up port forwarding on your router correctly?
  2. Does your router support NAT loopback?

I’m on a university network so I can’t directly change port forwarding on the router, although when I registered the device they claimed to have setup a static IP and hostname. I’m trying to diagnose whether it is a network issue or a Core issue. Have people successfully been able to ssh using public IP on Core 16?

This means your local PC/Laptop can not see this specific network, this has nothing to do with ubuntu core. You are not even getting far enough through the network to attempt a connection. Can you reach any other devices on this network block ? have you tried to use tracepath or ping to see where the network connection attempt ends ?

I’ve used tracepath but a fair amount of the end traffic is blocked. I’ve contacted the university network administrators and it seems that’s the issue. Still not resolved, but don’t think it has to do with Ubuntu Core. Thank you for all of the help!

1 Like