Can't get snapd to installed on Fedora 35 with Gnome 41.3

[user00@fedora ~]$ sudo dnf install snapd Last metadata expiration check: 0:47:54 ago on Mon 21 Mar 2022 06:15:01 PM PDT. Dependencies resolved.

Package Architecture Version Repository Size

Installing: snapd x86_64 2.54.4-1.fc35 updates 14 M Installing dependencies: snap-confine x86_64 2.54.4-1.fc35 updates 2.3 M

Transaction Summary

Install 2 Packages

Total download size: 16 M Installed size: 63 M Is this ok [y/N]: y Downloading Packages: (1/2): snap-confine-2.54.4-1.fc35.x86_64.rpm 2.4 MB/s | 2.3 MB 00:00
(2/2): snapd-2.54.4-1.fc35.x86_64.rpm 6.7 MB/s | 14 MB 00:02

Total 6.5 MB/s | 16 MB 00:02
Running transaction check Transaction check succeeded. Running transaction test Transaction test succeeded. Running transaction Preparing : 1/1 Installing : snap-confine-2.54.4-1.fc35.x86_64 1/2 error: lsetfilecon: (/usr/libexec/snapd/snap-confine;62392e58, system_u:object_r:snappy_confine_exec_t:s0) Invalid argument error: Plugin selinux: hook fsm_file_prepare failed

Error unpacking rpm package snap-confine-2.54.4-1.fc35.x86_64 Installing : snapd-2.54.4-1.fc35.x86_64 2/2 error: unpacking of archive failed on file /usr/libexec/snapd/snap-confine;62392e58: cpio: (error 0x2) error: snap-confine-2.54.4-1.fc35.x86_64: install failed

Error unpacking rpm package snapd-2.54.4-1.fc35.x86_64 Verifying : snap-confine-2.54.4-1.fc35.x86_64 1/2 Verifying : snapd-2.54.4-1.fc35.x86_64 2/2

Failed: snap-confine-2.54.4-1.fc35.x86_64 snapd-2.54.4-1.fc35.x86_64

Error: Transaction failed [user00@fedora ~]$

Installs fine here. Maybe a problem with a mirror? Have you tried removing the packages from dnf cache and trying again? If this persist it’s probably best to reach out to Fedora infra folks on IRC.

yes I tried removing the packages from dnf, but it’ telling there is no package installed. I’ll reach out to Fedora. Thank you much!

The package failed to install, as it failed to unpack, so there is nothing to remove. I suggested removing it from dnf package cache via eg. dnf clean packages command.

I tried all that, but it didn’t fix the issue, so I decided to reinstall the OS. Thank you much mborzecki for helping, have a great week!

Tri