Can't disable LXD service autostart

I stop and disable, but service stil listed as “enabled” and starts on next boot. Why is that?

user@host:~$ snap services
Service       Startup  Current   Notes
lxd.activate  enabled  inactive  -
lxd.daemon    enabled  active    socket-activated

user@host:~$ sudo snap stop --disable lxd.daemon
stop of [lxd.daemon] 
Stopped.

user@host:~$ snap services
Service       Startup  Current   Notes
lxd.activate  enabled  inactive  -
lxd.daemon    enabled  inactive  socket-activated

What is snap version?

Also what is snap changes ?

This comand disables the service on my system.

sudo snap disable lxd.daemon