Cannot launch snap-store (or any snap app)

Hello- I cannot launch the snap-store (or any snap app) no matter what I do (It may be something dumb as I am new to linux). I am on a chromeos device running debian linux 10 and no matter what I do, when I run “snap run snap-store” or “sudo snap run snap-store” it will not do anything. I can execute the command, just nothing happens and I cannot input another command. I have tried reinstalling snap-store, snap, linux, etc. but nothing is working. Any help is appreciated. Thanks!27%20PM

To simplify research why no snaps works, can you please install hello-world snap and run it with strace:

sudo snap install hello-world
snap run hello-world
snap run --strace= hello-world

and post results here.

This is what I get:

jackaroo@penguin:~$ sudo snap install hello-world
Warning: /snap/bin was not found in your $PATH. If you've not restarted your
         session since you installed snapd, try doing that. Please see for more details.

hello-world 6.4 from Canonical✓ installed
jackaroo@penguin:~$ snap run hello-world
Hello World!
jackaroo@penguin:~$ snap run --strace= hello-world
error: cannot find an installed strace, please try 'snap install strace-static'