Can no longer run any installed snaps (elementary 5.1, ubuntu 18.04 base)

Running elementary os 5.1 (based on ubuntu 18.04 LTS).

Upon clicking to launch a snap-installed app, the icon appears in the dock for about 30 seconds - but the app GUI window doesn’t load - and then the icon disappears. This happens with all installed snaps and launching from the command line offers no clues, for example:

$ bitwarden
$

In a bid to find the problem, I tried running under sudo but this creates permission errors:

$ sudo bitwarden
mkdir: cannot create directory '/run/user/0': Permission denied

Any ideas on how to find the cause of these apps not launching and how to fix it?

$ snap list
Name               Version                     Rev    Tracking       Publisher       Notes
bitwarden          1.24.6                      40     latest/stable  bitwarden✓      -
core               16-2.48.2.1                 10823  latest/stable  canonical✓      core
core18             20210128                    1988   latest/stable  canonical✓      base
gnome-3-28-1804    3.28.0-19-g98f9e67.98f9e67  145    latest/stable  canonical✓      -
gtk-common-themes  0.1-50-gf7627e4             1514   latest/stable  canonical✓      -
icedrive           1.2.6                       7      latest/stable  icedrive        -
signal-desktop     1.39.6                      346    latest/stable  snapcrafters    -
simplenote         2.6.0                       482    latest/stable  snapcrafters    -
slack              4.12.2                      36     latest/stable  slack✓          classic
snapd              2.48.2.1                    11036  latest/stable  canonical✓      snapd
standard-notes     3.5.18                      31     latest/stable  standardnotes✓  -
wps-office         10.1.0.6757                 1      latest/stable  liuyang8        -

$ snap version
snap        2.48.3+18.04
snapd       2.48.3+18.04
series      16
elementary  5.1.7
kernel      5.4.0-65-generic