Call for testing: Telegram Desktop


#21

@findo What’s your locale?

As I’ve noticed the same here with some text written in chinese… So it might be the case to include those fonts.


#22

Hey,

I’m still very happy with the snap but I’ve stumbled across a few issues:

  1. I can’t play a downloaded .wav file within telegram. Playing .mp3’s works fine.
  2. clicking “Show in folder” doesn’t do anything. Probably related to the issue I’ve reported before.
  3. superscript characters don’t get displayed correctly (see pic). Superscript isn’t that big of a deal but I can only assume that applies to other special characters as well.


#23

Hi, it works fine - only having one minor issue.

What I often do is to copy a link in my browser and paste it automatically in a telegram chat via chrome or firefox share extensions (there are many).

When I do this with the “old” telegram desktop application the telegram currently runnig telegram instance is opened and I can select the chat
When I do this with the snap version, a NEW instance of telegram is additionally opened and I would need to login again with my credentials.

Best regards


#24

Give a try to the latest --edge version as I’ve changed something on that, but I’ve actually to switch to the desktop interface soon, so it should fix those issues too.


#25

Please make sure you don’t have other telegramdesktop.desktop files around in your ~/.local/share/applications as the default app would generate those and they might break such things.


#26

Oh, Okay… that was strange. For some reason I had even more telegram clients! Sorry for the fuzz, everything works fine! I can use those extensions without a problem! Best regards

Edit: wow! The unread badges in the launcher work with the snap version! For some strange reason that does not work with the “normal” version.
Edit2: there are currently three telegram snap versions in the snap store - would it be possible to remove those unmaintained two?


#27

One question regarding themes:

I use the soon to be default (we all hope =)) theme “Communitytheme” which is not yet included in the snap (obviously because it is still under construction)
Yet, it is almost ready and I allready use it. Is there any way to copy the themes folder into the snap folder?
Atm it still falls back to adwaita. I tried to copy it into “/snap/telegram-desktop/54/usr/share/themes/” but my terminal response with “cp: cannot create directory ‘/snap/telegram-desktop/54/usr/share/themes/Communitheme’: Read-only file system”


#28

Output of locale is:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE="en_US.utf8"
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES="en_US.utf8"
LC_PAPER=fi_FI.UTF-8
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

EDIT:
nvm, seems to be fixed when running from edge channel :+1:


#29

@findo Good to hear, that is using the desktop-interface so it’s pretty expected.

@frederik-f a way to do it is copying that theme inside ~/snap/telegram-desktop/current/.local/share/themes (create it if misssing) instead.


#30

Sadly the same output:

frederik@xps:~/snap/telegram-desktop/current/.local/share/themes$ cp -r /usr/share/themes/Communitheme/ ./
cp: cannot create directory ‘./Communitheme’: Read-only file system


#31

Ah, right @frederik-f… That’s because ~/snap/telegram-desktop/current/.local/share/themes is already a link to the snap content, so doing it in ~/snap/telegram-desktop/current/.themes instead (removing the sym-link first) should work too.


#32

my telegram-desktop doesn’t start anymore ( kubuntu 18.04).
I’m kinda lost as I don’t know where debug logs for snaps go, to maybe figure out what is wrong


#33

this is:
https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1756793


#34

wow, thanks, that was fast response:
fixed it.
Strange, got some other snaps that still worked fine ( e.g. slack)


#36

Anyone experiencing message loss when both phone and telegram-desktop are running with the latest snap 1.3.9?


#37

@Trevinho Hi, I can’t use ibus IME in this official telegram snap package, you can find the details here: https://github.com/telegramdesktop/tdesktop/issues/4449


#38

Any chance for another armhf update? 1.3.10 started crashing a lot on Raspbian Stretch and apparently a newer update fixed this issue.