Call for testing: Telegram Desktop

Its a small issue, but I would love to see spell checking in some future version.

You’d have to request that upstream :slight_smile:

Just installed it and it’s working great! We even have accentuated characters working now! :smile:

Thanks a lot for this, your repository for the snap it’s like a tutorial to show how to push the limits of snapcraft, I’m sure it will help a lot of people packaging hard to snap apps! Great work!

1 Like

I’ve just installed it on Solus :slight_smile: I was worried about drag and drop files, in app updater and locale settings but everything works fine :slight_smile:

still I’m getting a few minor errors:

When clicking on a group chat after startup [mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f3cb8004140] Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol

When clicking on “Download” link to open the telegram downloads folder Error org.freedesktop.DBus.Error.AccessDenied: Supplied URL scheme "" is not allowed Error org.freedesktop.DBus.Error.ServiceUnknown: The name com.canonical.SafeLauncher was not provided by any .service files

@popey / @Wimpress - Do you feel this is a good move to put the current snap over to the snapcrafters repo?

I saw it but it doesn’t look something caused by the container, or is it? Do you get the same in the upstream version?
That comes from ff_configure_buffers_for_index in libavformat.

That’s a knonw issue valid for all the desktop snaps, and I’ve been discussing this a bit in Allowing xdg-open to open files

I have one issue, when on wayland

sergiusens@mirkwood:~$ telegram-desktop 
This application failed to start because it could not find or load the Qt platform plugin "wayland"
in "".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.
sergiusens@mirkwood:~$ snap info telegram-desktop
name:      telegram-desktop
summary:   Official desktop client for the Telegram messenger
publisher: 3v1n0
description: |
  Telegram is a popular messaging protocol with encryption and security as
  its key focus.
  Fast and secure desktop app, perfectly synced with your mobile phone.
snap-id: jpdoHqMd90M39DdH2JSZbeQxipqHtwLo
  - telegram-desktop
tracking:    stable
installed:   1.2.6 (54) 99MB -
refreshed:   2018-02-09 18:30:48 -0300 -03
  stable:    1.2.6                  (54) 99MB -
  candidate: 1.2.6                  (54) 99MB -
  beta:      1.2.7-alpha+git94cf307 (58) 99MB -
  edge:      1.2.8-alpha+git7814ee0 (60) 99MB -

In telegram-sergiusens that was solved by faking the wayland related environment variable to force using the X11 backend (in case you don’t want to go the wayland route just yet).

I just installed it here on Kde Neon and it is not working with accentuated letters. When I use it from a ppa, it works, though. I would like to provide any further information that is needed to debug this.

And thanks for the initiative.

As discussed elsewhere, I have the same issue as @gsilvapt here. Tried several workarounds but could not get it to work just yet.

The work for me, but I set up the keyboard to English (International AltGr dead keys)

Mh, @niemeyer could you strace the app without containement and with the env variables you need to get the letters to work, to see what Compose file loads?

Works fine. Only having problems when trying to change default download folder. folderfolder_select

@sergiusens weird, I’ve added the environment since some snap revisions now… It should go in wayland. :o

@findo What’s your locale?

As I’ve noticed the same here with some text written in chinese… So it might be the case to include those fonts.


I’m still very happy with the snap but I’ve stumbled across a few issues:

  1. I can’t play a downloaded .wav file within telegram. Playing .mp3’s works fine.
  2. clicking “Show in folder” doesn’t do anything. Probably related to the issue I’ve reported before.
  3. superscript characters don’t get displayed correctly (see pic). Superscript isn’t that big of a deal but I can only assume that applies to other special characters as well.

Hi, it works fine - only having one minor issue.

What I often do is to copy a link in my browser and paste it automatically in a telegram chat via chrome or firefox share extensions (there are many).

When I do this with the “old” telegram desktop application the telegram currently runnig telegram instance is opened and I can select the chat
When I do this with the snap version, a NEW instance of telegram is additionally opened and I would need to login again with my credentials.

Best regards

Give a try to the latest --edge version as I’ve changed something on that, but I’ve actually to switch to the desktop interface soon, so it should fix those issues too.

Please make sure you don’t have other telegramdesktop.desktop files around in your ~/.local/share/applications as the default app would generate those and they might break such things.

Oh, Okay… that was strange. For some reason I had even more telegram clients! Sorry for the fuzz, everything works fine! I can use those extensions without a problem! Best regards

Edit: wow! The unread badges in the launcher work with the snap version! For some strange reason that does not work with the “normal” version.
Edit2: there are currently three telegram snap versions in the snap store - would it be possible to remove those unmaintained two?

One question regarding themes:

I use the soon to be default (we all hope =)) theme “Communitytheme” which is not yet included in the snap (obviously because it is still under construction)
Yet, it is almost ready and I allready use it. Is there any way to copy the themes folder into the snap folder?
Atm it still falls back to adwaita. I tried to copy it into “/snap/telegram-desktop/54/usr/share/themes/” but my terminal response with “cp: cannot create directory ‘/snap/telegram-desktop/54/usr/share/themes/Communitheme’: Read-only file system”