Call for testing: snapcraft 3.9

Hello Snapcrafters! The Snapcraft team is delighted to announce that version 3.9 is now available.

These are the release notes (currently being drafted).

The snapcraft snap for 3.9 currently available in the candidate channel, to try it out run:

$ sudo snap install --candidate --classic snapcraft
Of, if you already have it installed, to try it out run:

$ sudo snap refresh --candidate snapcraft


When building core18 snaps, I get the following error message.

Snap 'grade' was set to 'stable' but must be 'devel'.

Recommended resolution:
Set 'grade' to 'devel' or use a stable base for this snap.
Run the same command again with --debug to shell into the environment if you wish to introspect this failure.

I’m not sure why I’m getting this since core18 has been stable for a long time.

name: kcalc-merlijn
version: 19.08.0
grade: stable
adopt-info: kcalc

confinement: strict
base: core18

    common-id: org.kde.kcalc.desktop
    command: kcalc
      - kde-neon
      - home
      - opengl
      - network
      - network-bind
      - pulseaudio

    interface: dbus
    name: org.kde.kcalc.desktop
    bus: session

      - usr/share/metainfo/org.kde.kcalc.appdata.xml
    plugin: cmake
      - kde-frameworks-5-core18-sdk
      - kde-frameworks-5-core18
      - libmpfr-dev
      - libgmp-dev
      - kdoctools-dev
      - libmpfr6
      - libgmp10
      - "-DCMAKE_BUILD_TYPE=Release"

Also, it might be best to grant autoconnection of kde-frameworks-5-core18 before releasing this snapcraft version, since kde-neon extension snaps don’t work without the connection.

Are you building on Launchpad with non-stable versions of the core18, core or snapcraft snaps?

I’m building on my laptop (using multipass). I’m not sure how to select the core18 version or check which version I’m using.

I’m using snapcraft from the candidate channel. (3.9, 3673)

I too am getting Snap 'grade' was set to 'stable' but must be 'devel'. on the snaps I’m testing with. lp:~ubuntu-desktop/gnome-system-monitor/snap for example.

Where you are building is the key to figuring this one out.

And where are you using core18 from?

Actually I see this locally too when building with multipass and have a core18 snap installed on my host that is on the edge channel.

Yeah, that will do it… that base could have a multitude of bugs in it which you wouldn’t want to have make into a stable channel by accident, considering the base is used to determine many attributes from the snap at build time, you wouldn’t want to be releasing a snap that only works when using core18 from edge to a stable channel.

I’m building in multipass from beta channel on Ubuntu 18.04. core18 on the host is from stable.

Inside the multipass container.

multipass@snapcraft-eog:~$ snap list
Name       Version   Rev   Tracking  Publisher   Notes
core18     20191010  1223  -         canonical✓  base
snapcraft  3.9       3673  -         canonical✓  classic
snapd      2.42      4992  -         canonical✓  snapd

On the host.

$ snap info core18
name:      core18
summary:   Runtime environment based on Ubuntu 18.04
publisher: Canonical✓
license:   unset
description: |
  The base snap based on the Ubuntu 18.04 release.
type:         base
snap-id:      CSO04Jhav2yK0uz97cr0ipQRyqg0qQL6
tracking:     stable
refresh-date: 16 days ago, at 15:26 BST
  stable:    20191010 2019-10-15 (1223) 57MB -
  candidate: 20191030 2019-10-30 (1265) 57MB -
  beta:      20191030 2019-10-30 (1265) 57MB -
  edge:      20191030 2019-10-30 (1265) 57MB -
installed:   20191010            (1223) 57MB base

OK, will look into this.

$ snap list
Name          Version     Rev    Tracking     Publisher          Notes
core          16-2.42     7917   stable       canonical✓         core
core18        20191010    1223   stable       canonical✓         base
snapcraft     3.9         3673   candidate    canonical✓         classic

Issue should be fixed on edge, it will make it into candidate after the automated battery of tests is done.

3.9.1 can be found on candidate, fixing the issue reported by @galgalesh, @popey and @ijohnson


I can confirm this works now.


Yeah, I’ve run a few snaps under lxd but having real trouble with multipass. Not sure if that’s a local issue for me, my system or what. Need to investigate further.

This lot built successfully with 3.9.1 in candidate. I installed a few and they worked fine.

✓ - dosbox-jz-snap (use-lxd)
✓ - irssi (lxd)
✓ - links (lxd)
✓ - mutt (use-lxd)
✓ - ddgr (lxd)
✓ - googler (lxd)
✓ - helm (use-lxd)
✓ - axel (use-lxd)
✓ - brackets (use-lxd)
✓ - brave (lxd)
✓ - corsixth (use-lxd)
✓ - cumulonimbus (lxd)
✓ - discord (lxd)
✓ - discord-ptb (lxd)
✓ - dosbox-x (use-lxd)
✓ - duckmarines (lxd)
✓ - eclipse (use-lxd)
✓ - fkill (lxd)
✓ - get-iplayer (lxd)
✓ - ghost-desktop (use-lxd)
✓ - gitter-desktop (use-lxd)
✓ - inadyn (lxd)
✓ - irccloud-desktop (use-lxd)
✓ - jenkins (use-lxd)
✓ - magic-wormhole (use-lxd)
✓ - mattermost-desktop (use-lxd)
✓ - mdl (use-lxd)
✓ - minetest (use-lxd)
✓ - mrrescue (lxd)
✓ - mumble (use-lxd)
✓ - offlineimap (use-lxd)
✓ - opentoonz (use-lxd)
✓ - opentoonz-morevna (use-lxd)
✓ - atom (lxd)
✓ - opentyrian (lxd)
✓ - pyradio (use-lxd)
✓ - scummvm (lxd)
✓ - sdlpop (use-lxd)
✓ - sentry (lxd)
✓ - simplenote (use-lxd)
✓ - slack-term (lxd)
✓ - spelunky (lxd)
✓ - storjshare-gui (lxd)
✓ - sublime-text (lxd)
✓ - tcpie (use-lxd)
✓ - teleconsole (lxd)
✓ - term2048 (lxd)
✓ - tmnationsforever (lxd)
✓ - vagrant (use-lxd)
✓ - vscode (lxd)
1 Like

I tested 3.9.1 with the following snaps:

  • drawing (Uses gnome-3-32-1804 content snap, no extension)
  • gnome-nibbles (uses gnome-3-28 snapcraft extension)
  • gnome-characters (uses gnome-3-28-1804 content snap, no extension)

All built using multipass. All built successfully and run as expected.

1 Like