Call for testing powershell-preview *please read first**

After some change in snapcraft and DotNet Core our snap broke on most distributions.

Can I get some testing on different distributions? Please use the following channel with fixes for all the issues

sudo snap install powershell-preview --classic --channel=edge/fixlibicu

Suggested tests:

  1. Run the snap and make sure it doesn’t crash for at least a minute.
    • Verify most libraries load. We do some background work for various reasons. The minute is to wait for that.
  2. Run Invoke-WebRequest https://www.google.com
    • Verify crypto library loads, so, SSL is the key here.
  3. Run Install-Module Pester -force
  4. (Requires Pester from step 3) run the following, and one test should pass and one should fail:
Describe "Verify Pester" {
 It "Passing Test" {
   1 | Should -Be 1 
 }
 It "Failing Test" {
   2 | Should -Be 1
 }
}

Results should look something like this:
image

1 Like

Hi Travis,

I’ve tested successfully on:

  • Ubuntu 19.10
  • Ubuntu 18.04.3
  • Ubuntu 16.04.6
  • Ubuntu 14.04.6
2 Likes

Everything successful here on Debian 11 (bullseye) / WSL.

3 Likes

I ran the tests on Ubuntu 19.10 and everything worked as expected for me.

Thanks.

3 Likes

elementary OS and Fedora 31 running fine in my test environment.

I updated the snap based on code review. Just moved setting some environment variables from the wrapper into the YAML.
I’ve verified 18.04 and 16.04. I’m going to release this, but please continue to test. We want feedback on the preview, before it becomes stable.

Installs and runs on Manjaro 18.1.2 but unable to install the Pester module.

image

Also having this issue on stable version. Unable to troubleshoot the issue so far. Any suggestions?

This is a known issue. The SSL certs for OpenSSL are not on the machine. I have not figured out how to resolve this. You didn’t run the Invoke-WebRequest test?

Yes, Invoke-WebRequest worked fine.

I was not aware this was a known issue. Any workaround?

If Invoke-WebRequest worked fine. Then, it’s not the same issue. I’ve not been able to get Invoke-WebRequest to work. Any clue how you got that to work?

It just worked out of the box. What kind of error should I have “expected” with Invoke-WebRequest?

I am also having trouble with registering PSGallery in PSCore on windows, an entirely different machine. Also a different error.

The problem I’m seeing it that it cannot establish the SSL connection because it doesn’t trust the cert (not CA’s are installed).

Let’s keep the discussion here limited to the snap package.